PuTTY - Unable to telnet out from MS Telnet Server

At work we have a MS Telnet Server that we use to then access various devices across the network.  At the moment I am using a program called Token2 to access the MS Telnet Server but this is rather limited in functionality.

Normally I use PuTTY for Telnet / SSH / Console however I have a slight issue when using it with MS Telnet Server.  I can login to the Telnet Server fine, but then when I try to telnet to a device, the command prompt just sits there:-

-----------------------------------------------------------------------------------------

Welcome to Microsoft Telnet Service

login: domain\username
password:

*===============================================================
Welcome to Microsoft Telnet Server.
*===============================================================
U:\>telnet 10.99.199.253
U:\>

-----------------------------------------------------------------------------------------

Is there a setting within PuTTY that I need to change to allow this?

MS Telnet Server is Windows Server 2003 R2 with SP1.  I can RDP to the server and then use PuTTY from the desktop without a problem.

Thanks,
soreilly80Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

giltjrCommented:
This should have nothing to do with Putty.  It should have to deal with the telnet client on the computer that you telnet'ing to in the first place.

Putty only knows about the telnet session between your computer and the Windows Telnet server.  It knows nothing about the attempted telnet session between the Windows Telnet server and the device.
0
soreilly80Author Commented:
When I use another program to telnet from my workstation to the Telnet Server and then onto a router, the display is correct, I get the proper device prompts etc.

I'm wondering if there is a setting that needs to be changed in PuTTY to change the way Telnet Server sessions are handled.
0
giltjrCommented:
Um, I tried putty and one other telnet client and neither of them worked.  The only one I got to work is MS's default telnet client.

My guess is that MS's telnet server is doing something weird that is causing problems with other telnet clients.  I'll have to do some more  testing with other telnet clients.
0
giltjrCommented:
Not sure what is going on.  I have tried:

  MS Telnet client
  HyperTerm
  Putty
  BlueZone

MS Telnet Client and Hyper Term allow you to run MS telnet client through a telnet session.  However Putty and Bluezone do nothing.  I am assuming that it is some type of incompatibility between the originating telnet client, MS Telnet server, and MS Telnet Client.

I still going to try and figure this out, but it could just be one of those MS things.  A combination of a poor telnet server and a poorer telnet client.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
soreilly80Author Commented:
Closing question due to no further updates forthcoming. Have searched the internet for other answers but not found anything.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.