XP DNS problem?

The problem:
---------------

Dell dimension 3100 connected to a DSL modem via ethernet cable.

When I connect my laptop to this modem, I have no problems accessing the Internet.
So, the modem and DSL services are OK.

The Dell shows:
* IE will not retrieve any web pages "The address is not valid"
* settings: never dial a connection; LAN settings = auto detect
* I can ping 216.239.59.99, but not www.google.com
* IE gets google if I put in the IP address, but not the URL



What I have tried
--------------------

* ipconfig /all shows exactly the same results for the Dell as for my laptop
* try static IP address
* disable Bullguard antivirus and firewall
* ipconfig /flushdns  [http://technet.microsoft.com/en-us/library/cc781949.aspx]
* winsock XP fix      [http://www.snapfiles.com/get/winsockxpfix.html]
* netsh int ip reset  [http://support.microsoft.com/kb/299357]

What else can I try?
johniathomeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Hi,
what does ipconfig /all show regarding nameservers? If your DSL router acts as a dns slave, add its address there, else add your provider's dns address.
0
johniathomeAuthor Commented:
to woolmilkporc:

ipconfig /all shows the ip adresses of OpenDNS servers:

208.67.222.222
208.67.220.220

...which looks fine to me.
0
woolmilkporcCommented:
Does a 'tracert' to those DNSs reach them?
Can you ping them?
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

johniathomeAuthor Commented:
To woolmilkporc:

I can ping and tracert both OpenDNS addresses OK - that's what's got me stuck.

If I can ping them, why aren't they working as DNS servers should?
0
woolmilkporcCommented:
Did you try  ipconfig /registerdns ?
What is the result of  ipconfig /displaydns
- any cache entries?
Have a look at your hosts - file, too. Perhaps strange things in there?

0
johniathomeAuthor Commented:
To woolmilkporc:

ipconfig /registerdns made no difference

ipconfig /displaydns shows:

Windows IP Configuration

         1.0.0.127.in-addr.arpa
         ----------------------------------------
         Record Name . . . . . : 1.0.0.127.in-addr.arpa.
         Record Type . . . . . : 12
         Time To Live  . . . . : 604489
         Data Length . . . . . : 4
         Section . . . . . . . : Answer
         PTR Record  . . . . . : localhost

         localhost
         ----------------------------------------
         Record Name . . . . . : localhost
         Record Type . . . . . : 1
         Time To Live  . . . . : 604489
         Data Length . . . . . : 4
         Section . . . . . . . : Answer
         A (Host) Record . . . : 127.0.0.1

The hosts file shows one entry:  

127.0.0.1       localhost
0
takendownCommented:
What does nslookup for google.com look like.  If you are getting a valid answer then it may not even be a DNS issue.
0
woolmilkporcCommented:
Did you try to reach  http://welcome.opendns.com/
(or in your case http://208.67.219.99 ) ?
What does it say?
 
wmp
0
woolmilkporcCommented:
... pardon
http://208.67.219.99/welcome
 
wmp
 
0
johniathomeAuthor Commented:
To takendown:

nslookup for google.com gives:

Server:  resolver1.opendns.com
Address:  208.67.222.222

Non-authoritative answer:
Name:    google.com
Addresses:  209.85.171.99, 72.14.207.99, 64.233.187.99

This looks OK to me, so what should I try next?
0
woolmilkporcCommented:
Hi,
seems that it is actually no DNS problem.
I fear it comes from some malicious thing on your machine. Try to find and remove it with SuperAntiSpyware -
http://www.superantispyware.com/
They say it could be from C:\WINDOWS\system32\ejansr.exe
Do you find this thing at your machine?
 
wmp
0
woolmilkporcCommented:
... and if it's (hopefully) not malware, try to fix it by installing Service Pack 3 (if not yet done).
 
wmp
 
0
takendownCommented:
I think just to be safe I would probably try another browser..Firefox 3 perhaps just to ensure that it is definitely a problem with IE.  Once this is determined or before if you'd like, check for any possible proxy settings configured in Internet Properties.  Uninstall any items that appear to be add-ons from Add/Remove Programs.  For Example: Any Yahoo 3rd Party, any other Internet Explorer Toolbars, etc.

woolmilporc's recommendation of running anti-malware is a good one, although I would recommend malware bytes from http://www.malwarebytes.org.  SuperAntiSpyware has caused me some bluescreen issues with some vundo variants in the past.  If malwarebytes can run it's update routine then the latest definitions can be found at the bottom of the download page for the app itself.  It's a standalone .exe and the area of the page looks like this:
Latest Database
Download from GT500.org <-Link

If FF3 won't browse for you either then we definitely have a windows problem.  Try the malware scan and you can always try system restore if enabled depending on your situation.  Let us know!
0
johniathomeAuthor Commented:
Thank you both for suggestions.

FF had same problem as IE, so it must be a Windows problem.

Superantispyware found nothing, and left the machine stuck at minimum screen resolution and 4-bit colour, which I could not change.

So, good old System Restore back 3 weeks, but the original problem is still there.

I cleared out some rubbish-looking browser add-ons, and used autoruns to disable some unlikely-looking auto-start suff, including a BHO.

Found a weird protocol installed (Something like "auto network protocol"), along with TCP/IP v4 and all the usuall stuff.
Googled and found it was related to Dell Network Assistant. Lots of web sites recommend uninstalling this.
However, it won't uninstall without the Dell CDs for some reason,
and I can't get these until Monday, so no more action untill next week.

Much more of this and I will wipe the machine and  run the Dell Restore - that will definitley fix it!
0
johniathomeAuthor Commented:
I ended up running the Dell Restore to solve this. Not very satisfactory in terms of understanding the cause of the problem, but it worked. I also uninstalled Dell Network Assistant, as recommended by several web sites.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
woolmilkporcCommented:
I understand that you do not want go give us the points. So, at least, give us back the time we spent working on your question. Will you?
wmp
 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.