Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1768
  • Last Modified:

WSUS server not downloading new updates

Hi All,

I noticed the space on my WSUS server running 3.0 SP1 on Windows 2000,  was dwindling so i thought i would move them to a different external drive which is plugged in through USB. that has plenty of space.

I ran the command line file - wsusutil movecontent and it went over okay - Moving the files from C TO F - See Log File.

However since then none of the files that i have since approved for download are coming down.  I have run the server clean up wizard and also run the reset command - wsusutil reset  - and that seemed to download all the files that i have previously approved before but if fails at these three that i have approved since.

On event viewer it is bringing up the following error:

Content file download failed. Reason: Value does not fall within the expected range. Source File: /msdownload/update/v3-19990518/cabpool/netfx30sp1_x86_8d779e337920b097aa0c01859912950606e9fc12.exe Destination File: F:/WSUS\WsusContent\12\8D779E337920B097AA0C01859912950606E9FC12.exe.

It seems to know the correct destination so i am a tad bemused.

Any ideas.
WSUS.LOG
0
NobbyGee
Asked:
NobbyGee
  • 13
  • 8
1 Solution
 
NobbyGeeAuthor Commented:
Sorry that should have read Windows 2003 server not windows 2000 server
0
 
Netman66Commented:
I think that resetting your Proxy settings should cure the issue.

See this thread for an explanation.

http://www.eggheadcafe.com/software/aspnet/30864773/event-ids-364--10032.aspx

Those 3 failures likely have an EULA to agree to before they download.

0
 
NobbyGeeAuthor Commented:
I have tried to reset again and it brought up the ERROR CONNECTING TO WSUS.  Before i reset the node i have copied the error code:

The WSUS administration console was unable to connect to the WSUS Server via the remote API.

Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.

System.Net.WebException -- The operation has timed out

Source
System.Web.Services

Stack Trace:
   at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
   at Microsoft.UpdateServices.Internal.DatabaseAccess.ApiRemotingCompressionProxy.GetWebResponse(WebRequest webRequest)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.UpdateServices.Internal.ApiRemoting.ExecuteSPGetUpdateServerStatus(Int32 updateSources, Boolean includeDownstreamComputers, String updateScopeXml, String computerTargetScopeXml, String preferredCulture, Int32 publicationState, Int32 propertiesToGet)
   at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.ExecuteSPGetUpdateServerStatus(UpdateSources updateSources, Boolean includeDownstreamComputers, String updateScopeXml, String computerTargetScopeXml, String preferredCulture, ExtendedPublicationState publicationState, UpdateServerStatusPropertiesToGet propertiesToGet)
   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.GetStatus(UpdateSources updateSources, Boolean includeDownstreamComputers, UpdateScope updatesToInclude, ComputerTargetScope computersToInclude, UpdateServerStatusPropertiesToGet propertiesToGet)
   at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.GetReplicaStatus(UpdateSources updateSources)
   at Microsoft.UpdateServices.UI.SnapIn.Common.CachedUpdateServerStatus.GetFreshObjectForCache()
   at Microsoft.UpdateServices.UI.AdminApiAccess.CachedObject.RefreshCache()
   at Microsoft.UpdateServices.UI.AdminApiAccess.CachedObject.GetFromCache()
   at Microsoft.UpdateServices.UI.SnapIn.Pages.ServerSummaryPage.backgroundWorker_DoWork(Object sender, DoWorkEventArgs e)

Does that mean anything

I don't think it can be the firewall as they were downloading fine until i moved the wsus content location.

It is downloading the updates again and i will keep you informed:

 
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
NobbyGeeAuthor Commented:
It has stuck now on only downloading 15,000 of 73124,34 mb

On the event viewer it states.
The server is failing to download some updates.

0
 
Netman66Commented:
You may want to simply remove WSUS and start over.

After removing WSUS run this command to ensure the MSDE instance is also removed cleanly:

msiexec /x {CEB5780F-1A70-44A9-850F-DE6C4F6AA8FB} CALLERID=ocsetup.exe

Reinstall things and let us know.
0
 
NobbyGeeAuthor Commented:
Yes i may try that next week , will keep you informed.
0
 
NobbyGeeAuthor Commented:
I seem to be having issues reinstalling - Maybe it has not been unistalled as it keeps bringing up the following error:
An instance with the same name is already installed on this computer. To proceed with SQL server setup,provide a unique instance name

I can not seem to find the sql server anywhere to rename or even delete - I take it is the same name as the server itself. The windows internal database is in the add/remove but will not be removed as it says it is not in use.  I attach the logs for the error.

Any ideas?




WSUSWyukonSetup-081118-1152.log
WSUSSetup1.log
0
 
Netman66Commented:
Did you run this?

msiexec /x {CEB5780F-1A70-44A9-850F-DE6C4F6AA8FB} CALLERID=ocsetup.exe

Were you using an SQL DB for WSUS?

0
 
NobbyGeeAuthor Commented:
Ran that and it all it states is that this action is only valid for products that are currently installed.

I don't think we were i just took the recommended settings over when we upgraded to 3.0 sp 1 where it has the different interface.

Does that not use a different sql database when upgrading.  

0
 
Netman66Commented:
No, you needed to run the upgrade with the /G switch.

You'll need to go into the registry under:

HHKEY_CLASSES_ROOT\Installer\Products and figure out what GUID represents the SQL 2005 express install then substitute that GUID in the command I posted above.

0
 
NobbyGeeAuthor Commented:
There is not an SQL 2005 Express in there see screenshot.

The ones from Microsoft in there are:

MSXML 6 SP2
NET FRAMEWORK 3.0 SP1
NET FRAMEWORK 2.0 SP1
PLATFORM SDK
PRESENATATION FOUNDATION
REPORT VIEWER 2005

Under Program Files there is an SQL Server folder with an 80 and 90 folder in
Capture2222.JPG
0
 
NobbyGeeAuthor Commented:
I do have sysmi folder in windows which has SQL 2005 IN:

C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL

That has the following folders:

Backup
Binn
Data
Install
Log
SchemaSig

Should i be able to find that in Registry?
0
 
Netman66Commented:
Ok, check in the registry under:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Search for the word "Embedded".
When you locate it there should be an uninstall string present in the key.
Copy the uninstall command from the key to the Run box and add the "CALLERID=ocsetup.exe" to the end of the line.

Reboot to take effect.

Let me know.
0
 
NobbyGeeAuthor Commented:
No joy with the search for embedded - The Windows internal Database is listed in that section with the uninstall string same as the code you have mentioned to me in previous posts.

With the upgrade to 3.0 sp1 - We used the Windows Internal Database as we do not have SQL 2005 on this server.

I will reboot the server tonight anyway after all the changes today anyway.

Capture2223.JPG
0
 
Netman66Commented:
OK.  I suspect a reboot is necessary now as you ran that command previouslyand it needs to finish up.

You should be good to go then.
0
 
NobbyGeeAuthor Commented:
No luck after the reboot,  still stops at the same point stating that the:

An instance is already installed on this computer. To proceed with the SQL Server set up, provide a unique instance name.

Any ideas?  Very frustrating now.
0
 
NobbyGeeAuthor Commented:
Please find latest logs.

Seems okay until it gets to the Windows Internal Database starts.


WSUSWyukonSetup-081119-0839.log
0
 
Netman66Commented:
OK, uninstall WSUS and run that command to remove the DB.

Before you reboot again, delete the SSEE folder and content.
Check the registry for any lingering keys that related to SQL 2005 express and remove them.
Reboot and retry the install.

0
 
NobbyGeeAuthor Commented:
By using unlocker i have deleted the program files SQL SERVER and also the ssee folder - Without a reboot still no joy. Will do one shortly.

I have found SQL under regedit - See screen shots can i delete all of these:

0
 
NobbyGeeAuthor Commented:
Screenshots sorry about that
Capture2225.JPG
Capture2226.JPG
0
 
Netman66Commented:
It looks like you can safely remove those registry entries before you attempt a reinstall.

0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 13
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now