Exchange + SBS 2003 Std - OWA not working using SSL

Hi. Bit of a strange one that I really appreciate some help with.

Out of the blue, OWA over SSL stopped working. Error is the usual IE page can not be found - no IIS related hints to point me in the right direction.

I've now got it working using HTTP, but I don't want this to be long term and need to get a fix so that we can start using HTTPS.

Cert's are self signed and appear to be OK. Default Web has been stopped, started and checked without any success.

Hardware Firewall has been fully checked and 443 is pointing to the SBS.

Thanks in advance.

Derek


Lawrie GormleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Toni UranjekConsultant/TrainerCommented:
Hi!

Can you access your server's 443 port from local network or server itself?

Toni
0
leegclystvaleCommented:
Do you host the DNS record for the server or is it outside? Worth checking that's not been deleted/changed
0
Lawrie GormleyAuthor Commented:
Hi - Thanks for the fast response.

Couldn't access the server's 443 from the LAN or the server itself and the DNS record for the server is hosted externally. As far as I'm aware, no changes have taken place.

Cheers

Derek
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Toni UranjekConsultant/TrainerCommented:
Go to command prompt and run the following command:
netstat -an

Does port 443 appear and is it listed as Listening?
0
Lawrie GormleyAuthor Commented:
Port 443 does appear as listening with a local and foreign address of 0.0.0.0

Have a look at the screen shot. Server's local IP address is 10.10.0.5 and there are three instances of the 443 state being "TIME_WAIT"
0
tristan20Commented:
Can you try the IP address instead of the name?

Also did you try FBA? Enable it or disable it and try it

http://www.petri.co.il/configuring_forms_based_authentication_in_exchange_2003.htm
0
Lawrie GormleyAuthor Commented:
Tried the IP address - no change - looking at FBA right now.

Cheers

Derek
0
Lawrie GormleyAuthor Commented:
Got it fixed - turned out to be a corrupt SSL self signed cert. Put in a new one and off it went.

Thanks to you all for help.

Cheers

Derek
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSL / HTTPS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.