Issues connecting to share..."Logon failure: account currently disabled"

I've just installed Windows Server 2008, which will be used as a domain controller and file server for our office.

I'm trying to set up a share that each of the users in the office can use as a central file storage location.  Each time I try to connect using something like this '\\myserver', I get this response:

"\\myserver is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

Logon failure: account currently disabled."

Yet I'm never prompted for any credentials.  The PC I'm attempting to access from is not yet part of the domain.  I can ping the server by both ip address and name.

Are there some domain group policy settings that I need to set to allow free access to a share on this server?
howardsdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tigermattCommented:

Is the username you are logged in with locally on this test PC the same as a user which was created on the server? If it is, then even though the PC is not a domain member, the credentials of that user account will be used for authorisation. It would appear the account on the server with that name is disabled, thus causing this error message to appear.

-tigermatt
0
McKnifeCommented:
As you can read here for example: http://technet.microsoft.com/en-us/library/cc766343.aspx
--
"Disabling the Built-in Administrator Account
Original equipment manufacturers (OEMs) and system builders are required to disable the built-in Administrator account before delivering the computers to customers"
--
So if the account at your server is still disabled and you try to use \\server with the local admi account at the workstation, this behavior is normal.
0
howardsdAuthor Commented:
Is there no way to pass a domain user's credentials (that may be different from the current local user) when accessing the share?

This share has Everyone > Full control has it's access privileges.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

McKnifeCommented:
Of course there is: use a domain account that has logon permissions from everywhere (logon to: all computers) and make use of the net use command
net use i: \\server\share\ /user:domain\domainuser domainuserspassword
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
howardsdAuthor Commented:
"Of course there is: use a domain account that has logon permissions from everywhere (logon to: all computers) and make use of the net use command
net use i: \\server\share\ /user:domain\domainuser domainuserspassword"

Not sure what you by "(logon to: all computer).  I'm a noob at this stuff.

Is there no way to open up a share on the server that does not require authentication...just free and open access to anyone in the network?
0
tigermattCommented:

The easiest methods are of course to just enable the account on the server, or just make the station a member of the domain. The root fact is that this is expected behaviour: even if you opened the share with 'Full Control', the connection is not even reaching that stage, because the server is refusing to authenticate the server before even considering opening the share.

-tigermatt
0
McKnifeCommented:
logon to all computers is the default option for any domain account, so unless you changed it, this will not be the problem.
For your other concerns, read http://www.databaseforum.info/13/21/50c833fe49612852.html
0
howardsdAuthor Commented:
The solution accepted works great.

Points should be awarded.
0
howardsdAuthor Commented:
Looks like my first attempt at accepting got screwed up.

Got everything working.  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.