Error on Organization prerequisite

Trying to install exchange 2k7 on windows 2008 box with a current 2003 exchange installation in the domain that we will be migrating from.  When i run the Readiness checks i get 3 pass and 1 fail..the one that fails is the organization one.. i get

Error:
The Active Directory Schema is not up-to-date and Ldifde.exe is not installed on this computer. You must install Ldifde.exe by running 'ServerManagerCmd -i RSAT-ADDS' or restart setup on a domain controller.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.3&id=511f5dc2-d9d0-4dc4-bfb1-5e125d6e99e6

Warning:
The Active Directory schema will be upgraded if you continue. Verify that the organization is ready for Exchange 2007 by running the Exchange 2007 Readiness Check, which is part of the Exchange Best Practices Analyzer.


Elapsed Time: 00:00:06

I've tried running that command from both command line and powershell..nothing..still get errors?  anyone know?
LVL 1
jasonmichelAsked:
Who is Participating?
 
jasonmichelConnect With a Mentor Author Commented:
i used mstsc /console to login ...that fixed it
0
 
hodgeyohnCommented:
1.  is the command running successfully?
2.  are you a schema admin for your domain?
0
 
jasonmichelAuthor Commented:
i can't tell if the command is running successfully from cmd line because the screen goes away too fast..but the powershell errors

heres the wierd thing...the account i log into exchange server is a schema admin.  but i get errors when i try to install, so i "run as admin" and it allows me to install..just fails on the readiness
0
 
hodgeyohnCommented:
are you using an admin, or the original administrator built in account?
0
 
jasonmichelAuthor Commented:
i am using a domain admin account to log in..but i just right click and "run as administrator"
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.