• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6915
  • Last Modified:

Unable to send mail through Trend Micro IMSS

Hi,
I'm installing Trend Micro IMSS on windows 2003 server. This server have the internet ip address of my domain mail address (ex. mycompany.com).
I've a netware 6.5 server also with tha Novell Groupwise GWIA that send and receive mail through IMSS server.
The w2k3 server is replacing an old w2k with IMSS 5.7 that function properly with GWIA.
Now, when I move the cable from old to new server I can receive but can't send mail.

Thanks for help
Giancarlo
0
Mattia Minervini
Asked:
Mattia Minervini
1 Solution
 
JoWickermanCommented:
Hi nanoweb,

What does the event viewer say? Does the new server have the same name and IP address as the old server?

Cheers.
0
 
Mattia MinerviniAuthor Commented:
Hi JoWickerman,
the server has different ip address and host name BUT, both servers (old and new) are connected to internet through a firewall with NAT and when I connect the new server I change the NAT settings to move the public ip address (and the DNS name) to new server.
On the event monitor I see this error: "denied because recipient domain is not in the allowed domains list".
This is what I see in IMSS settings:

imss1.jpg
imss2.jpg
imss3.jpg
imss4.jpg
0
 
JoWickermanCommented:
Hi

Did you enter your new Server's internal IP in the Permitted Senders of Relayed Mail box? I see there's a 192.168.0.2 address. Is this the new or old server's address?

What is listed under the Delivery Methods tab?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Mattia MinerviniAuthor Commented:
Hi,
192.168.0.2 is the GWIA server.
this is what I see in Delivery methods tab.

imss5.jpg
0
 
JoWickermanCommented:
Oh... This makes better sense now...

The issue is not on your MS server. It's on the Novell server. The SMTP on the GWIA points to the wrong address! You must edit it to point to the new server's address!
0
 
Mattia MinerviniAuthor Commented:
no, when i change server obviously I change the ip address in GWIA to point to the new server.
0
 
JoWickermanCommented:
Ok, now I am confused...

The clients sends mail to the GWIA server who uses the Win2K3 server as mail forwarder. Trend Interscan is installed on the Win2K3 server and when you changed to the new server, you changed the IP address of the forwarder on the GWIA server?

Enter the Win2K3 server's IP address to the Permitted Senders of Relayed mail as well as default Delivery method on the Delivery Methods tab.

You might want to change the port in this tab as I see you specify secure SMTP, but tell the GWIA to use port 25 in the Default Delivery Method.
0
 
Mattia MinerviniAuthor Commented:
You Wrote:

>>>The clients sends mail to the GWIA server who uses the Win2K3 server as mail forwarder. Trend >>>Interscan is installed on the Win2K3 server and when you changed to the new server, you changed >>>the IP address of the forwarder on the GWIA server?

Yes.

>>>Enter the Win2K3 server's IP address to the Permitted Senders of Relayed mail as well as default >>>Delivery method on the Delivery Methods tab.

I've ried this but mail are not sent. The IMSS log says "could not be relayed and was deleted, with failure notifications email sent".
The sender of email received an email that says "Delivery Final Failure Notice. Can not deliver the message you sent. Will not retry."
0
 
JoWickermanCommented:
Untick enable secure SMTP on the SMTP Connections Routing page and test mail.

Let me know, cause there might be one more thing I can think of.
0
 
JoWickermanCommented:
Oh yes...

1.       Log on to the IMSS Web Console.
      
2.       Go to Administration > IMSS Configuration > SMTP Routing.
      
3.       Click the Connections tab.
      
4.       Under the Connection Control section, select Deny All, except the following list.
      
5.       Select Single Computer.
      
6.       Add the IP address of the mail server from which you IMSS to accept the connection.
      
7.       Click the >> button.
      
8.       Click Save.
0
 
FourBeersCommented:
I blieve on the Delivery Methods tab, under Default Delivery method, this should be empty.  I've just had to do a similar upgrade and I believe by default it uses DNS to route outgoing emails if this part is left empty.  My understanding is that this setting is for outgoing mail, and it is redirecting all your outgoing mail to 192.168.0.2.
0
 
Mattia MinerviniAuthor Commented:
Hi JoWickerman
I,ve tried both solutions but no good news.
Here You can see the IMSS console monitor.

For FourBeers: tried your solution also: doesn't work.

imss6.jpg
0
 
JoWickermanCommented:
Hhhhmmm...

This looks like a rule has been set in place to block ALL mail! Check under Global policy. All your filters should be listed here. Check through all of them and make sure that there's not one that blocks mail if a filter is triggered AND blocks mail if a filter is not triggered!

I have seen how a person have deleted all mails for a coporate company by selecting delete if the filter applies and delete if the filter does not apply!!!

Change the setting to allow if the filter is not triggered.
0
 
Mattia MinerviniAuthor Commented:
no rules are set up.
The errors that you can see in IMSS monitor are coming after setting this

>>>4.       Under the Connection Control section, select Deny All, except the following list.
>>>5.       Select Single Computer.
>>>6.       Add the IP address of the mail server from which you IMSS to accept the connection.

Thing that I already tried before after reading the Solution # 1036564 from Trend Micro Knowledgebase.
     
0
 
JoWickermanCommented:
Oh ok... Change the setting to Accept all and untick the use secure smtp.
0
 
Mattia MinerviniAuthor Commented:
Done,
I continue to receive mail but can't send.
0
 
JoWickermanCommented:
What error message do you receive when you send mail?
0
 
khpiraniCommented:
hey. did you solve this problem, i have same problem as well, can u plz tell me how u solved this issue.
0
 
Mattia MinerviniAuthor Commented:
modifying ip addressing of all subnet....maybe a problem with some firewall rules.
sorry.please close
0
 
cahinosayanCommented:
Permitted senders of Relayed mails must be your SMTP server and set to single computer only.
Default delivery method should be empty - it's used for outgoing mails.
Domain delivery method should be your domain.com then SMTP address:25 (port 25) - this is used for incoming emails. this fix my problem. God bless. Jayson
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now