Setting up Linksys wireless router as a pass through?

Posted on 2008-11-12
Last Modified: 2012-05-05
This should be easy but for some reason cannot get the configuration correct. Our Internet router handles DHCP and assigns 10.1.10.x addresses. I have a Linksys wireless router that I want to plug int the same switch that the Internet router is plugged into. I just want the wireless to act as an access point so wireless devices can get Internet and access to servers etc.. Can't seem to set this up correctly. I logged into the wireless router and turned off DHCP. After I do that and try to renew the IP on the PC plugged into the router, it says it cannot find the DHCP server. If DHCP is on then the PC hooked up to the router gets a 192.168.x address and can get to the Internet but in now on its own network segment. I tried turning off DHCP on the router and changing the mode from Gateway to Router (as it is not acting as a gateway...) and still unable to grab a 10.x address with the PC plugged into it. I want to assign the rounter a static IP so I can always find it to admin it. I assigned it a 10.x address. Since that is coming from the Internet Router, the wireless router sees that as the external or internet address. From what I understand I cannot assign the router's internal IP to the same subnet or else it cannot properly route. Is that correct? This router use to have machines plugged into it and it was working fine. Once it is setup as an access point there was no way to login to admin it so I reset it. Now I cannot get it functioning correctly again.

Thanks for any help.
Question by:ctamucci
    LVL 1

    Expert Comment

    What model of Linksys router are you using?

    Author Comment

    Sorry, I listed it in the tags section but not in the body of the questions- WRT54GS V.7 .

    LVL 1

    Accepted Solution

    Have you considered just plugging into the LAN port (which is a switch)?  

    I have two WRT54G routers in my study tied to a Cisco 2600 series router.  The connections to the linksys routers connects to their LAN ports with DHCP turned off and the Windows DC serving DHCP.  Effectively, the WRT54G becomes a switch and access point.

    Author Comment

    Voila! You hit it on the head. That was my whole problem. Don't use the Internet port when you are trying to make the router an access point.

     Funny thing though now- I turned off DHCP on the router. Also enabled WPA2-AES. I can connect wirelessly to the router but it immediately tells me I have an IP address conflict with another PC on the network. Release/Renew does not help. Tried power cycling the laptop and router. Disabled and re-enabled thewirless NIC. I reset the router and reconfigured to confirm that DHCP was turned off. Still no luck. I then went into my TCP/IP settings andset static addresses. Now I connect fine. Haven't tested it but the concern is other users try to connect with DHCP and have trouble. Ever seen this?
    LVL 1

    Expert Comment

    (1) make sure you only have one DHCP server.
    (2) always draw out your network.  I label all of my devices and computers with a labeller showing their hostname and IP.
    (3) post your network topology somewhere as a reference.  For me that is next to my rack.

    Documentation makes troubleshooting real easy.

    Now assuming you have one router (RTR A) which is the internet router, connected to a switch (SW B) which is tied to LAN port x on the WRT54G (AP C), then we should have the following.

    RTR A is DHCP.  It's lan config is (example) (routers should be 254)
    SW B doesn't have an IP
    AP C has DHCP turned OFF (important).  It's IP is

    The DHCP server in RTR A should be starting at and issue IPs from 100 to 250.

    You can then connect a computer and configure it as to test the network on a static IP.

    If you are assigning an IP the DHCP server has issued...well...that would give you the error you reported.

    Author Comment

    Thanks. I have our topology all mapped out and it is really simple. Internet Router and WRT54GS are both plugged into a 24-port switch that connects our 17 PCs. The only other piece of network hardware is a hub to connect out workgroup printers.

     Turns out one of the printers was the issue. When Xerox came to set it up they gave it a static IP that was within the IP range DHCP was leasing. My laptop kept grabbing that address. I changed the IP on the printer to something outside of DHCP range and everything is fine. Thanks again for the help. I'll award full points.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
    David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    25 Experts available now in Live!

    Get 1:1 Help Now