Outlook 2007 unread messages not showing all in inbox

In the inbox of one of my users new emails comming in are showing up as unread but not showing up in the inbox.  When we do a search on unread messages all the messages are shown.  When we look in the Inbox some of the messages are not listed while others are.  We checked on his Blackberry and found the messages listed in his inbox but again not in Outlook inbox.  Any suggestions?  We are running Vista business and Office 2007.
nuke2computerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Hello nuke2computer,

Look at the other folders and subfolders for the missing emails.  Do you have a filter to move emails to other folders?

Hope this helps!
war1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mdrcoastCommented:
Make sure under view/current view  last 7 days is not checked
0
nuke2computerAuthor Commented:
There is no sub folders nor is the last 7 days checked.  The emails in question all came in reciently with in a few minuites of eachother.  
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ALogvinCommented:
In my experience it is typically a filter that causes this. Look in the bottom right hand corner in Outlook when you are looking at his inbox. You should see something like "86 items". If it says "75 Items (filtered)" you know your problem.
0
DavidT543Commented:
Long shot - but check your inbox to see if you have in advertantly set a filter

view > current view > customise current view > filter
0
war1Commented:
Look at the bottom of the email list.  The date on email may be wrong, so sorted to the bottom of list.
0
nuke2computerAuthor Commented:
You all mentioned various filters and settings, I looked through the outlook further and found the reset View to default which cleared the problem.  While none suggested that directly they all lead me to a solution so I am splitting the points amoung all.  I hope you all find that fair.
0
ALogvinCommented:
Glad to see you found it! The "Views" are filters in outlook by the way... when you enable it you hit the "View" menu, but when its turned on, microsoft calls it a "filter" :)
0
arjaycomputersCommented:
I was having this problem and this is what worked for me:
Go to VIEW>ARRANGE BY>CURRENT VIEW>CUSTOMIZE VIEW, then click on the RESET CURRENT VIEW button at the bottom.  Worked for me 100%. It resets anything that has ben chaged back to its defaults.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.