Local Admin Account Can't Install or Uninstall Software

Hello All,

     I have installed Windows Vista on a laptop and added the laptop to the domain.  Everything seems to be working just fine.  I added the user that will be using the laptop as a local admin like I have done with many other systems so they can add or remove software.  When I add this user as a local admin however they can add or remove software.  Not to sure what is going on here.  Any ideas?
fv858Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

asian_niceguyCommented:
what is the exact error message when attempting to do this?
0
sk_raja_rajaCommented:
post the event log messages ?
0
alienvoiceCommented:
Have you given the domain acct which they r logging in with Admin rights within Vista?

Need to go to the Users acct and check via the ctrl panel. Added them to the Admin grp.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

sk_raja_rajaCommented:
Part of the Vista security structure is that normal "administrators"
have only standard privileges. If you are in this category you must take
ownership of the file or folder in order to delete it.

http://www.vistax64.com/tutorials/67717-take-ownership-file.html
0
fv858Author Commented:
When I try to add or remove software I get a popup asking for the User Name and Password.  Only way to install it is using a domain admin account.  
0
McKnifeCommented:
Could it be this: If you enforce a certain policy, elevation only takes place after entering credentials, even for administrators. But this would also affect domain admins - does it? Does it affect domain admins as well, or are you only saying when you are asked for credentials, you entered the domain admin's name and pw and it worked?
If that policy is in effect, you would be able to install after entering your own credentials again.

Policy: security settings - local policies - sec. options - User account control: Behavior of the elevation prompt for administrators in Admin Approval Mode
" Prompt for credentials: An operation that requires elevation of privilege will prompt the Consent Admin to enter their user name and password.  If the user enters valid credentials the operation will continue with the applicable privilege
0
fv858Author Commented:
Yes....i went into control panel and went to User accounts on the laptop.  I added the user as an Administrator on that machine.  It asked for my domain admin account and password. It then lists the user as an administrator.  After that I try to install a program like Adobe Reader and I get a popup asking for the domain admin account and password.
0
McKnifeCommented:
Could it be you forgot to logout and in again? After promoting the user from restricted to admin, that user has to log in again before it becomes active (he gets the new token at logon).
0
fv858Author Commented:
No tried logging in and out and it didn't work.  Couldn't install any app.  Now I did get it to work but am a bit unsure why.

In Active Directory I moved the Computer object into the Sales OU which is where the user object is located.  There are two folders one is Users and the other Computers.  I just dragged the computer object into the Computers folder under sales and it worked.  Now she can install software from the network as well as install/uninstall any other programs on her laptop.  Not sure why that would not allow her to remove her own programs on her system.
0
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mortoncrconsultantCommented:
I have a new laptop with Home Premium installed. I have tried several things such as use the command prompt to create an ADMINISTRATOR account. I ran the regedit file above.  Still can not install as administrator.  I was able to install several programs, but will not install yahoo messenger.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.