Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 472
  • Last Modified:

Epson, TI-88III stops working requiring complete uninstall and re-install of driver and supporting software

I have a system running Quickbooks POS (7) with a Epson TI88III thermal printer and a Handheld Products bar code scanner. The printer had stopped working so I uninstalled the driver and related software and re-installed. I could not find a driver on epson's website and resorted to driverguide to get one.

After installing the driver, the printer was working again. However as soon as I plugged the scanner back into the system I got a 'problem with usb device' message. After re-installing the scanner's drivers (once again from driverguide - seems Handheld Products is out of business), and uninstalling/re-installing the printer again a test page printed correctly.

I then opened Quickbooks to test things, opened the cash drawer (processed by printer), and printed a receipt. The printer in Quickbooks had changed to another device, so I changed it back. After doing this Windows said it found new hardware (it shouldn't have), then that a problem occured during installation of said hardware. Device manager showed the Epson usb port (not the printer driver itself) with an exclamation point - details said it could not start. I re-installed this driver and the printer is still not working.

Any thoughts on what might be going on? I didn't get a chance to re-install the printer again. (note: the Epson usb port driver is installed with the printer installer package).
0
m3tech
Asked:
m3tech
  • 2
1 Solution
 
slam69Commented:
i would uninstall your usb controller and reinstall but it could be a bad connector for that port. do you have any other usb ports to try?

If all else fails serach for teh usb.inf file and name it old, shut down reboot and reinstall could be corruption to that file but its doubtful
0
 
m3techAuthor Commented:
This turned out to be a combination of: 1) a bad usb cable (slapped myself for not changing this sooner); 2) A power issue with the number of devices on the usb ports; 3) Very finicky drivers, both of which I could not get from the manufacturer.

A new usb cable, extra pci usb card, and some work fighting driver installs and all is well.
0
 
m3techAuthor Commented:
Not a total solution, but good troubleshooting advice.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now