Exchange Active Sync/OMA Problem... very frustrated...

Hello all,  I'm new here so here goes...

I'm trying to enable active sync for my iPhone on Exchange 2003, SP2 stand alone server on Windows 2003 server.  Here is the error that I'm getting after trying a few things.  Seems like I'm really close... hopefully someone has seen this one before?

Unable to connect to your mailbox on server WINDOWS2003. Please try again later. If the problem persists contact your administrator.

When I look in Event Viewer here is what I'm seeing:

Event Type:      Error
Event Source:      MSExchangeOMA
Event Category:      (1000)
Event ID:      1805
Date:            11/13/2008
Time:            1:59:36 AM
User:            N/A
Computer:      WINDOWS2003
Description:
Request from user josh@Boddiford.com resulted in the Microsoft(R) Exchange back-end server WINDOWS2003 returning an HTTP error with status code 501

Response:
Content-Length: 0
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 6.0.2.6568
Date: Thu, 13 Nov 2008 06:59:35 GMT


Original Request:
Content-Type: text/xml
Depth: 0
Content-Length: 389
Expect: 100-continue
Host: windows2003
.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Josh-TampaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

florin_sCommented:
Hi,

Here is what I have found on another site:

Anonymous (Last update 9/4/2007):
In our case, we were getting EventID 1776 from source Davex and EventID 1805 from source MSExchangeOMA. We were unable to activesync and browse OMA directory. We successfully ran the command regsvr32 msxml3.dll, and we were able to activesync.

Jim Gleason (Last update 7/20/2006):
I had this issue and I needed to recreate the virtual directories. See M883380 for details.

Mihai Andrei (Last update 11/9/2005):
As per Microsoft: "This event indicates that the request made by the Outlook Mobile Access browse user was not successful because the back-end Exchange server returned an HTTP error code". See MSEX2KDB for additional information about this event.

This problem can occur if you have reached the storage limit for your mailbox. See M842023 for details.

Ionut Marin (Last update 2/26/2004):
See M817379 and M822177 to see why this occurs and how to fix it.  

and here are the links for the article above:

http://support.microsoft.com/default.aspx?scid=kb;en-us;883380

http://support.microsoft.com/default.aspx?scid=kb;en-us;842023

http://support.microsoft.com/default.aspx?scid=kb;en-us;817379

http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=6.0&EvtID=1805&EvtSrc=MSExchangeOMA&LCID=1033
0
Josh-TampaAuthor Commented:
Thanks so much for the reply.

I tried all suggestions that you provided but it has not made a difference unfortunately.  It seems that I'm getting different HTTP error codes for OMA versus ActiveSync.  When I look in event viewer it's showing the 501 error for OMA but it's showing the following for ActiveSync.

Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            11/13/2008
Time:            9:03:12 AM
User:            BODDIFORD\josh
Computer:      WINDOWS2003
Description:
Unexpected Exchange mailbox Server error: Server: [windows2003.Boddiford.com] User: [Josh@Boddiford.com] HTTP status code: [400]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
florin_sCommented:
For this event here is what I have found out:


Jerry Haskins (Last update 8/3/2008):
I started getting this error and mobile phones would not sync anymore after adding alias IP addresses to the server. After removing the alias IP addresses the error went away and mobile phones could sync with the Exchange server again.

Anonymous (Last update 9/10/2007):
In my case, these errors started when I implemented the use of host headers on my IIS web sites. I have two web sites on the Exchange server and started using host headers to distinguish them. To fix the issue I created an identity with a blank host header on the site hosting Exchange.

Mihai Andrei (Last update 7/4/2007):
This issue may occur if one or more following conditions are true:

1. The authentication method is incorrect for the virtual directories that are used by Microsoft ActiveSync.
2. The application name points to an incorrect entry in the Outlook Mobile Access virtual directory.
3. The application name points to an incorrect entry in the Microsoft-Server-ActiveSync virtual directory.
4. An incorrect application pool is associated with the virtual directories that are used by ActiveSync.

See M937635 for information on solving this problem.

Christian Egger (Last update 5/15/2007):
The meaning of this error depends on the HTTP Status Code it contains. 507 could mean that the users Mailbox is over its quota, which can cause a problem for Active Sync to save information in a hidden mailbox folder.

Bill Olah (Last update 2/4/2007):
This issue can appear if the security settings on the Virtual Directories are altered. Verify that the following settings are enabled for the front-end and back-end servers.

Front-end Exchange Server:

Default Web Site:  Basic Authentication
ExAdmin: Integrated Authentication
Exchange:  Basic Authentication
ExchWeb:  Anonymous
Active Sync:  Basic Authentication
OMA:  Basic Authentication (note: Default domain must be \)
Public:  Basic Authentication.

Back-end Exchange Server:

Default Web Site:  Anonymous, Integrated Authentication
ExAdmin: Integrated Authentication
Exchange:  Integrated Authentication, Basic Authentication
ExchWeb:  Anonymous
Active Sync:  Basic Authentication
OMA:  Anonymous, Integrated Authentication
Public:  Anonymous, Integrated Authentication.

Francois Couture (Last update 11/22/2006):
This solved our problem:

1. Right click on the virtual directory and click properties
2. Uncheck "Enable anonymous access" in Authentification method
3. Synchronize your PPC.

David Fosbenner (Last update 11/22/2006):
I got this event every 15 minutes on my Exchange 2003 system. The source of the error was a user's smartphone which was configured to use ActiveSync to synchronize with the Exchange Server. The smartphone had the Exchange server name and user credentials, but was not synchronizing successfully.  We decided to prevent the smartphone from using ActiveSync to sync with the server, and that eliminated the 3005 errors. Instead, the smartphone syncs using IntelliSync which came bundled with it.

Anonymous (Last update 11/12/2006):
For the past week or so, I have upgraded my domain to Windows 2003 native. My DCs were all previous running Windows 2000. The exchange server was running 2003 exchange on a 2000 server operating system. I upgraded my system to 2003 all of them without a hitch. I then installed SP2 for Exchange 2003. Everything seemed to work aside from ActiveSync. The weird thing is it worked half the time and the other half it did not. I would get an Active Sync HTTP_500 error on my palm and an EventID 3005 from source ActiveSync "Verify Exchange is working properly" on the server end.
For the past week, I have dedicated most of my time trying to fix this problem. I have tried every KB article I could find and every registry hack you could think of. I finally broke down and spent 100 bucks to contact Microsoft about the issue I noticed several other people on groups experienced. I figured I would post this to anyone else that might have this same problem with ActiveSync.

1. Open up Systems Manager (Start -> All Programs -> Microsoft Exchange Systems Manager).
2. Look for the "Servers" folder and drill down.
3. If you have a Front-End/Back-End (FE/BE) scenario like me you will have to do this fix to both machines.
4. Drill down to the server you want and then to "Protocols HTTP Exchange Virtual Server".
5. Once you have drilled down there, right click on the "Microsoft-Server-ActiveSync" and click Delete.
6. Right click on the "Exchange Virtual Server", click New, and then Virtual Directory.
7. Under Microsoft-Server-ActiveSync -> "Exchange Path" click "Exchange ActiveSync".
8. Then OK out of it.

Give it a shot, this worked for me.

Alaskowski (Last update 11/9/2004):
This problem is usually attributed to an Exchange situation involving excessive items in the users calendar. Refer to M842541 for hotfix.

Ger J. Kleinsman (Last update 7/14/2003):
This is an Exchange 2003 Pocket PC Server Activesync error.  

and here are the links:

http://support.microsoft.com/default.aspx?scid=kb;en-us;842541
http://support.microsoft.com/default.aspx?scid=kb;en-us;937635
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.