Problem with wpa_supplicant

Posted on 2008-11-12
Last Modified: 2013-11-12
Hi. I recently bought a Hawking HWUG1 and followed all the instructions from this link to be able to use it with my BackTrack 3 distro.

Here is the script I've written:
ifconfig rausb0 down
modprobe -r rt73
tar -jxvf rt73-k2wrlz-3.0.1.tar.bz2
cd rt73-k2wrlz-3.0.1/Module
make && make install
modprobe rt73 ifname=wlan0
cd ../..
tar -xzf wpa_supplicant-0.5.10.tar.gz
cd wpa_supplicant-0.5.10
patch -p1 < ../wpa_supplicant-ralink_rt73.patch
patch -p1 < ../wpa_supplicant-ralink_rt73-fix.patch
cp defconfig .config
cp wpa_cli wpa_supplicant /usr/local/bin
echo 'network={
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
psk=<key from wpa_passphrase>
}' > /etc/wpa_supplicant.conf
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf - d rt73 -w

The only thing that I didnt take from the instructions is "cp defconfig .config". The config file wasnt mentioned so I just copied the example. Now I get errors like this:

ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported

This is just from the cerr. Do you think it has to do with the configuration or the driver itself? Appreciate your help.
Question by:ezgigurkan
    LVL 1

    Accepted Solution

    i would say that this is a driver issue, you might need to find a driver for your exact model. do something like "lspci | grep rt" and see what output it gives you.

    i would suggest downloading the updated drivers from somewhere like this

    if your going to install new drivers dont forget to remove the old ones, the install instructions inside the drivers zip file should explain how to do this.

    Author Comment

    My drivers are definitely rt73, if that's what you're asking. I confirmed that from several sources.

    I followed the instructions and downloaded the source code but I don't really know what to do from here. The folder is massive with a lot of things in it. It doesn't look like it's just a driver. I tried typing `make` and `make install` but did not work. And I can't find any tutorials explaining what to do after downloading the source code. The README file seems to explain how to install a kernel and nothing else. I'm not sure why it's talking about a kernel and how it relates to the driver.

    Any ideas?

    Author Comment

    Apparently I was supposed to run something like `make menuconfig` before running `make`. I ran it, didn't set or change anything and saved the configuration as it was. After that, `make` worked and I think complied a billion .c files. But I got very similar wpa_supplicant output. Strangly enough I got a lot of messages in cout with the first driver but this one only gave me cerr output and nothing else. The same cerr output as before.

    What I figured is that what I got from the repository involved much more than drivers. I think I found where the drivers I want are. The folder contains a bunch of .c files, a Makefile and a Kconfig file. `make` fails with a "no targets" error. I got the impression from the Kconfig file that I need to write/change the Makefile myself according to which driver I have, which is something I cant do.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    With the purchase of CloudCommand by Comcast customers are left in a bind as subscriptions expire and render the AP's disabled. The following will explain how to flash your Ubiquiti AP's with CloudCommand firmware back to Ubiquiti firmware. HOWTO…
    In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
    This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now