NDR Language in Exchange 2007

Hello.
I have some troubles with NDR's in Exchange 2007 sp1.
What is it that sets the language?

My production environment:
2 CA+HT servers
3-node scc-cluster with 2 MBX-servers.
All is Exchange 2007 sp1 installed on windows server 2003 SP2.

My test environment
1 single Exchange 2007 ca+ht+mbx. Installed on windows 2003 R2.

I've set the following attributes (which i thought would solve my problem) in all HT-servers
ExternalDsnDefaultLanguage              : en-US
ExternalDsnLanguageDetectionEnabled     : False
InternalDsnDefaultLanguage              : en-US
InternalDsnLanguageDetectionEnabled     : False

It started with a german customer to us that resolved a NDR in swedish (everything resides in sweden, regional settings are set to swedish on all servers).

Then I started making some tests and here are the results.
n-e-a means non-existing address.
n-e-d means non-existing domain.
production.com is my external production domain. test.lan is of course my testenvironment.
Mails are routed between test and production with dedicated send connectors.

If I send emails from my production-exchange to n-e-a@production.com I get an NDR in English
If I send emails from my production-exchange to n-e-a@n-e-d.com I get a swedish NDR (could be my spamfilter)
If I send emails from my production-exchange to n-e-a@test.lan i get a swedish NDR (does not pass spamfilter)

If I send emails from my test-exchange to n-e-a@test.lan I get a NDR in English.
If I send emails from my test-exchange to n-e-a@n-e-d.com I get a NDR in English. (I have to manually remove this from exchange que with 'remove with ndr' since i got no internet send connector in my test-exchange)
If I send emails from my test-exchange to n-e-a@production.com I get a NDR in swedish.

If I send an email from my other company (I'm a consultant) to n-e-a@production.com I get a NDR in swedish.
If I send an email from my g-mail to n-e-a@production.com I get a NDR in English.

Why does NDR in swedish exists?
How can I manually set this to always be in English?

I'm stuck and all help is appreciated.
nncgAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

florin_sCommented:
the third is about setting it to english
0
nncgAuthor Commented:
I've read those articles and they refere to the setting InternalDsnDefaultLanguage.
And as I described earlier this setting is already set.

Just to test I've created a postmaster mailbox in my testenvironment and set the language to english.
No luck...  still in swedish. I've attached a header sent from my production to my test environment to a nonexistingaddress and I get a NDR in swedish.


Received: from ht1.production.com (xxx.xxx.xxx.xxx) by
 Testad1-vs-exch.test.lan (xxx.xxx.xxx.xxx) with Microsoft SMTP Server (TLS)
 id 8.1.240.5; Fri, 14 Nov 2008 09:59:38 +0100
Received: from mbx1.production.com ([xxx.xxx.xxx.xxx]) by
 ht1.production.com ([xxx.xxx.xxx.xxx]) with mapi; Fri, 14 Nov 2008
 09:59:37 +0100
From: "lastname, firstname" <firstname.lastname@production.com>
To: "'madfjasd@test.lan'" <madfjasd@test.lan>
Date: Fri, 14 Nov 2008 09:59:37 +0100
Subject: test
Thread-Topic: test
Thread-Index: AclGN1H6Z9A4CoHVT9KtjlxceMFShw==
Message-ID: <474FD948805B004BAE5621CD89DC13C23E75276A96@mbx1.production.com>
Accept-Language: sv-SE
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
acceptlanguage: sv-SE
Content-Type: multipart/alternative;
	boundary="_000_474FD948805B004BAE5621CD89DC13C23E75276A96SENWKSEXM1pap_"
MIME-Version: 1.0
Return-Path: firstname.lastname@production.com

Open in new window

0
nncgAuthor Commented:
Nobody knows anything more about this?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.