[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Mac-Mini Replaced HD, now won't start

Posted on 2008-11-13
21
Medium Priority
?
1,087 Views
Last Modified: 2013-11-24
Hi all,
I had a harddrive crash and decided to uprade by replacing the Apple HD 37gb with a 256gb WD. All that went smoothly except I cannot start it to reinstall the OS. When I start the Mini, I get a chime and the LED is solid. The DVD starts up and then the LED starts flashing (once per second). The DVD will spin down and then compuer will shut off after about 30 second. The display is a blank grey screen , except once or twice I got a blue(purple) screen with a forward button and redo buton. Also, I can't get the DVD ejected. I have tried without luck resetting PRAM, and replacing RAM (Apple Genius said it was a RAM problem) What does all this mean and what should I do? . Thanks for any help
0
Comment
Question by:PCGenieLA
  • 8
  • 8
  • 3
  • +1
21 Comments
 
LVL 3

Expert Comment

by:calltms
ID: 22949229
You need to check your specific Mac Mini model and ensure it is compatible with a drive that size. Also, make sure that you didn't accidently put a SATA2 instead of SATA drive in (if you did, there's a jumper on the drive you can set, which will force the SATA2 to perform at SATA speeds).

You need to have a USB attached keyboard to get this thing to boot correctly - I've never had any good luck with the Apple Wireless Bluetooth keyboards and try to do specific things while booting. When you boot the mini, hold down the eject button as soon as the screen is gray and hopefully the disc will eject. After that, turn it off and back on, put in your reinstallation disc and hold down Option this time to give you a choice of where to boot. Boot from your reinstallation disc.


Just in case you missed something . . .

http://www.gearlive.com/index.php/news/article/how_back_up_upgrade_the_mac_mini_hard_drive_05101143/
0
 
LVL 3

Expert Comment

by:calltms
ID: 22949232
Oh, also re-seat everything. Pull the RAM out and put it back in, same for hard drive.
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 22949355
When you boot the Mac, if you hold down the mouse button, the disk should eject.  If it doesn't, I would suspect something wrong with the optical drive or perhaps you missed something when hooking the drive back up.

I kind of suspect that this may be your issue anyway.  Obviously the HD can't boot and if the optical drive is not functioning properly or isn't hooked up it would give some weird startup thing.  Not familiar with what you are seeing on the screen... suppose the mobo itself could be having an issue.
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
LVL 28

Expert Comment

by:jhyiesla
ID: 22950551
Have you tried booting with the C key held down to force it to go to the install CD (DVD)?  Once there you would also have access to the Disk Utility which may help narrow down possible issues such as the ones mentioned by calltms.
0
 

Author Comment

by:PCGenieLA
ID: 22951696
1. I replaced the Hard Drive with a larger IDE drive., not SATA and I made sure all the connections were solid, including the Ram. I even swapped out the RAM for another similar RAM all without luck. As for booting and ejecting the CD, both operations have been tried with Keyboard and mouse. While I have been able to reset PRAM from the keyboard, ejecting the CD has not worked with the keyboard or mouse. I eventually had to take off he DVD drive's top and extract the CD. So, I suppose this might be a DVD drive issue., but how would I know?
0
 

Author Comment

by:PCGenieLA
ID: 22951710
I wish I knew for sure what the flashing LED means. The Apple Genius said memory, but the beep I get from the Mini when I leave the RAM out is completely different. Any ideas?
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 22951885
Found this good discussion thread on flashing lights and beeps.  It might help.

http://discussions.apple.com/thread.jspa?threadID=838782

Probably the only way to tell for sure about the optical drive is to put it in another known working mini or buy a new one and put it in yours.
0
 
LVL 53

Expert Comment

by:strung
ID: 22956592
Make sure the WD drive  is jumpered as Single.
0
 

Author Comment

by:PCGenieLA
ID: 22965688
I took the Mini apart today and found that one of the very small power plugs which powers the CPU fan, was loose.On repluggging it, and reassembling the unit, I found the flashing LED was resolved. Also, the unit now stays on. However, I still can't get the DVD drive to eject the Installation disk and I can't get the unit to boot to the disk. Eventually, the unit will display the greyish purple screen with the folder and question mark flashing, I guess, it can't find an OS). Any ideas what this means and what do we do now?
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 22965894
Assuming that the mobo itself hasn't failed, you're probably getting that because the HD is empty.  Now that things are working better try booting the Mac with the C key held down and see if you can get into the installer.  If you do, you should be able to run the disk utility from the menu after accepting the Language in the installer routine and from there you can initialize the HD and install OS X.  

I still think that something is most likely wrong with the DVD drive since you can't eject the disk.
0
 
LVL 3

Expert Comment

by:calltms
ID: 22965915
I agree with jhyiesla; you more than likely have a defective optical drive, but I still urge you to try this with a wired Apple keyboard (or Apple compatible, with the eject button on it like the cheap Belkin keyboards)


The file with a question mark means the drive is empty. It tried to boot from the hard drive and didn't know how. If your Leopard disc was conveniently stuck in there, it would've booted off of that and you'd be able to install Leopard.  At this point, you may need to look into copying the Leopard disc contents to a flash drive and try booting off of that. This time hold down OPTION on the keyboard - this should bring up a selection menu.


Also, try holding down your wireless mouse left click - this may eject.
0
 
LVL 53

Expert Comment

by:strung
ID: 22967339
Did you check the jumpers on the WD drive?

Also, what DVD are you using? Is it one that came with your particular Mini, or a full commercial OS X install?

If the DVD is and OEC DVD from a different model Mac, it won't work. OEM install DVD's are model specific. Also, you can't boot a Mac from a DVD that is older than the Mac itself.
0
 

Author Comment

by:PCGenieLA
ID: 22967939
WD drives default to single without a jumper. This one had no jumper. As for the DVD, it is the one that came with the Mini. Unless there is aother sugggestion, I suspect I'm going to have to replace the DVD drive, although I don't know why it would go out at this moment.
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 22967951
Your drive settings are probably OK, but check the old drive designation against the new one as far as whether the old was was set to Single, Master, Slave or cable Select. You want to make sure that your new drive has the same designation as the old one, which may be a different jumper config.
0
 

Author Comment

by:PCGenieLA
ID: 23014843
I'm going to replace the DVD drive and see if that's the problem, especially considering I can't eject the DVD at all. These hardware issues are always so frustrating; you have to replace the computer piece by piece and each piece requires another shipment of parts. We'll see.
0
 

Author Comment

by:PCGenieLA
ID: 23021517
Well, I installed a brand new DVD drive, same as the old one, and the symptoms remained the same. Using a two button USB mouse and a USB PC keyboard, I still can't get it to boot to installation disk I also can't get it to eject the disk. Also cannot get into the command line screen, but I can reset the PRAM and NVAM. No matter what I do, the Mini always ends up displaying the gey screen with the flder and question mark. Any thoughts about diagnosing a possible logic board failure? Any other ideas?
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 23021833
What happens now when you boot the Mac with the C key held down?

If you go to the CD, that would pretty much say that the optical drive and mobo is OK.

If you can't get to the installer with the C key held I suppose it could be the mobo, but I think you should carefully go back through and make sure that every connection is connected to the right thing and that it's tight... and reset the RAM.
0
 

Author Comment

by:PCGenieLA
ID: 23022385
When I boot with the C pressed, I get the chime, a gray screen and the DVD drive spins up for about  5 seconds and then spins down. Nothing else happens until about a minute has elapsed, when I get the folder with Mac Face and the question mark. The Mini stays on. I tried to boot also to the hardware test disk and got the same result. I have reset PRAM and VNRAM, using option command r and p. It does reset, but no behavior change. Also I can't eject disk.
0
 
LVL 28

Accepted Solution

by:
jhyiesla earned 1500 total points
ID: 23022572
Since you've replaced basically all of the single parts I'm guess that either the mobo has an issue, or you still have some cable somewhere not connected properly, the RAM needs reseating or something is shorting out within the case.  Obviously the "easiest" and cheapest is to fine-tooth comb the innards looking for anything out of place that could be causing the thing to misbehave.
0
 
LVL 28

Expert Comment

by:jhyiesla
ID: 23787725
PCgenieLA... did anything suggested here solve your issue?

If the you do not know how to close the question, the options are here:
http://www.experts-exchange.com/help.jsp?hi=407
0
 

Author Closing Comment

by:PCGenieLA
ID: 31516322
Since the MOBO is so expensive, I decided to just junk the unit. I'll buy a replacement at some later date. Thanks for your help anyway
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There is a security feature on iOS devices that is nearly impenetrable when it has been activated.  This article will provide some possible solutions as well as necessary steps to take to ensure you do not end up with a locked device.
Article by: Justin
In light of the WannaCry ransomware attack that affected millions of Windows machines, you might wonder if your Mac needs protecting. Yes, it does and here is how to do it.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question