LAMP-Linux-Apache-Mysql-PHP

Hi,
 I have installed RHEl-4 As .After  that i have installed apachce2.10,php5.26.mysql-5.45 .All the installations are done from tar ball installations.
after installation when starting the apache its giving error as follows
root@bg1ws0085 ~]#  /usr/local/apache2/bin/apachectl start
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: mysql_module_entry
. I am not getting the tings correctly.
I have to integrate php apache and mysql how to do that .how to rectify this error
krishguddAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fosiul01Commented:
for php and mysql you need to install

yun install php-mysql    

then from php.ini you need to enable extenstion  mysql.so


i always try to install php , mysql and apache by yum it never give me any problem.

can you not try to install php by yum ??
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lqwCommented:
I second that, try the Redhat-delivered packages first before using some tarballs. They are tested for your
system and should probably work out of the box. I don't believe you ned the latest versions, security updates are ported back into the Redhat-Packages...

lqw
0
krishguddAuthor Commented:
Hi,

I installed those softwares by tar ball installation.Tell me how can i change settings so that all three will be integrated.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

lqwCommented:
First, if you installed all those tarballs, I would reinstall the system because cleaning up this mess will be
difficult and probably not complete.
When you reinstall, you should be able to select this as part of the installation (LAMP system, Webserver or single selection of those packages)

If you don#t want to reinstall, you could try to clean up the mess either by having uninstall scripts or by hand and after that use the command system-config-packages to install the packages. You need
 X for this.

But for you expertise, I belive a clean reinstall would be the best.

lqw
0
fosiul01Commented:
ok in your php.ini file have you insert this line

AddType application/x-httpd-php .php
0
fosiul01Commented:
try to have a look this tutorial, and say you have done all thig things

http://blazonry.com/scripting/install_apache.php
0
Rance_HallCommented:
when you installed php the ./configure line has an option to allow for the building of the apache module or not, if you didnt use that option then no module was created.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.