server rejected the sender address

When I first configured the server I used an email address as the "reply to" address of no-reply@mydomainmame.com.  Then I setup a couple reports for email subscription delivery.  They worked for a while, but after a few days started to fail.  The message I get is:

Failure sending mail: The server rejected the sender address. The server response was: 554 Mail from no-reply@mydomainname.com rejected for policy reasons.

The server is a Lotus Notes Domino server.  I went back and changed the configuration to use my email address as the reply to address and ever since, it works sometimes (maybe 2 out of 5 times) and the other times I get the above error message.

I've looked at the server config files and verified the no-reply email address is not there at all.  I've restarted services and the server, etc.  But I still get some failures and some successes.  I can't find a pattern to it.  

Any ideas what is going on here and how to solve it?
Obeg_Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mekhet30Commented:
The server response was: 554 Mail from no-reply@mydomainname.com rejected for policy reasons.

This error is usually generated because of your Blacklist and Whitelist relay settings in your Configuration Document in the Domino Directory

I've had this problem before and for the life of me I cannot remember the exact fix.  I do remeber though that it was something with Inboud relay controls.  

Try this as a test:
Open the Domino Directory -> Messaging -> Configurations

Edit the cofiguration for the server in question.
Go to Router/SMTP -> Restrictions and Controls -> SMTP Inbound controls
Change the "Perform Anti-Relay enforcement for these connecting hosts:" to "none"
Save & Close

Stop and start the router task and rund the following console command "tell router update config"

See if you still get the error

Cheers
0
Obeg_Author Commented:
The Notes relay had to be recreated for this server.  It was previously set up, but recreating it solved the intermittent problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.