Host display issues in Cacti Syslog Plugin

Hello ,
I have installed Cacti syslog plug which is helping me see all the syslog-ng messages on my syslog-ng server. But looks like there is some problem with the config file. Becasue some of the hosts are displayed as fully qualified.

for example
aixser1
aixser2
sunser1.xyzcompany.com
sunser4.xyzcompany.com

I have read this http://www.campin.net/syslog-ng/faq.html#compression but this is not helping me.Any suggestions please
options
  {
    chain_hostnames(no);
    create_dirs (yes);
    dir_perm(0755);
    dns_cache(yes);
    keep_hostname(yes);
    log_fifo_size(2048);
    log_msg_size(8192);
    long_hostnames(off);
    perm(0644);
    stats(3600);
    sync(0);
    time_reopen (10);
    use_dns(yes);
    use_fqdn(no);
  };

Open in new window

jdenver247Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Add the short names of the hosts in question to your /etc/hosts file. This will help
0
jdenver247Author Commented:
But I have 28 host names which are displaying sunser.xyzcompany.com. Its very strange that this is happening only for the Sun servers. I am very much interested in tweeking the option. But I will try including some in my host file..
0
jdenver247Author Commented:
Adding hosts in /etc/hosts as
sunserv1  xxx.xxx.xxx.xxx  .......   didn't help
0
woolmilkporcCommented:
The format of an /etc/hosts entry is:

xxx.xxx.xxx.xxx sunserv1

Additionaly, in your /etc/nsswitch.conf you should have
hosts: files dns

If all the above doesn't help, I suspect your SUN hosts don't have an entry for themselves in their respective /etc/hosts, so they can't lookup their own short hostnames.

wmp


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.