OpenVPN routing help needed

I have been using OpenVPN for a while now to connect to my Linux box (10.0.0.98) from work (Windows XP Pro (192.168.4.0)).  I recently set up another server at home and I am experiencing difficulty connecting to it through the VPN.

Work Configuration (Client) IP Range 192.168.4.0
remote <myhomeip>
port 10000
dev tun
ifconfig 10.8.0.2 10.8.0.1
secret C:/Progra~1/OpenVPN/config/key.key
comp-lzo
keepalive 10 60
ping-timer-rem
tun-mtu 1500
persist-tun
persist-key
route 10.0.0.0 255.0.0.0

Home Config (Server 10.0.0.98) IP Range 10.0.0.0 GW 10.0.0.202
dev tun
port 10000
ifconfig 10.8.0.1 10.8.0.2
secret /etc/openvpn/key.key
comp-lzo
keepalive 10 60
ping-timer-rem
persist-tun
persist-key
push "route 10.0.0.0 255.0.0.0"

In the Router at home I have set up a static route -> destination 10.8.0.0 Gateway 10.0.0.98 metric 2

The Linux box server (FC7) has iptables turned off and IP Forwarding turned on.  All firewalls have been disabled on every computer concerned whilst I tested this.

From the client I can ping 10.0.0.98 (The Server) I can also ping 10.0.0.202 (The Home Router) but I cannot ping any other computer on the 10.0.0.0 network.

I can ping all computers on the Home network from any computer on the home network.

Any and all help will be greatly appreciated.
johncpowell1Asked:
Who is Participating?
 
Roachy1979Connect With a Mentor Commented:
Sounds like a problem with the reply path for the packets.....

See my recent blog post

http://technicalmumblings.wordpress.com/2008/11/10/connecting-to-a-host-on-using-an-alternative-gateway-with-openvpn/

Basically - the default gateway for the packets reply path needs to be the linux box that is running OpenVPN or at least there needs to be a route that says that packets for VPN clients need to be routed back over the VPN, rather than via the default gateway...


0
 
johncpowell1Author Commented:
Thank You. I was trying to avoid adding a persistant route to all the computers on the LAN (Server Side) but this solution will suffice until i set up the VPN Server to be the default LAN gateway.  Thanks Again. John
0
 
Roachy1979Commented:
No problem!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.