Site to Site VPN connection works fine, programs works fine, can ping but cannot map drives

We have a site to site VPN connection using Netgear FVS318 routers and so far the VPN connection works fine, we can use our programs and the connection stays alive all the time.  I can ping the ip of the remote computer but when I want to browse the folders or map the drive it says "\\192.168.1.254 is not accesible. You might not have permission to use this network resource..."  This is when I loggin to the computer using my username@domain.

When I log off and loggin using Adminstrator@computer I CAN browse the folder of the remote computer and I can map the drives.  The ipconfig is the same on both users but only works when I loggin as the Administrator@computer.

I already try to use the "Netbios over TCP/IP" on the advance configurations and didn't help.  I try to add exceptions to the firewall adding the ports 137-139 but still no go.  Please help.
LVL 5
vguzmanIT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SysExpertCommented:
This looks more like an issue with the shares and not the router.

Make sure that you are doing a Domain login.

2) Does DNS work - if not make sure that you get this working first so that server names are resolved by name


I hope this helps !
ricks_vCommented:
it might be the problem with MTU size issue.
try do ping from any machine at both end.
dos: ping x.x.x.x -f -l  1300

1300 is the value you need to keep changing, find the highest value that ping can be successful.

if you get say, 1350 as max. use a program called "tcp optimizer" and change he mtu size for client pc at remote end to 1350 , and try do file sharing again.

This issue can be resolve using other method, like changing mtu size on your router. but wont mention as things get more complicated.

give it a go, let me know the pign result, so i can assist further
vguzmanIT ManagerAuthor Commented:
Thanks for the help.  I have tried to browse the remote computer by name an by IP like I said but it didn't work.  The DNS is working fine.  Also the MTU is setup at 1430.  I found out that it could be a username credentials problem cause we have different domain names at each location.  I try to use the command:
net use \\remote\sharefolder password /u:domain\username  and it worked !! but now the problem its that I have to do this everytime I log off an login again.  I also tried to add the /persistent:yes at the end but when I reboot (which is not that often) the mapped network drive ask for username and password.  Is there another way how to fix this ?
Thanks again.
Defend Against the Q2 Top Security Threats

Were you aware that overall malware worldwide was down a surprising 42% from Q1'18? Every quarter, the WatchGuard Threat Lab releases an Internet Security Report that analyzes the top threat trends impacting companies worldwide. Learn more by viewing our on-demand webinar today!

vguzmanIT ManagerAuthor Commented:
its :    net use \\remote\sharefolder password /u:domain\username /persistent:yes
without the </A> like it shows in the previous comment

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
2hypeCommented:
you could try the following.

create a username and password on the remote computer which is the same as the username and password you use to log onto your machine it should open up without prompting you for credentials.

make sure the username you created has rights to that share.
vguzmanIT ManagerAuthor Commented:
I already tried that but still not working.  I set up the rights to the share folder, included that usename in the administrator privileges and nothing changed. Could it be cause it's a different domain name ?
 
2hypeCommented:
Yeah the fact its a different domain name is the problem.
I mentioned on the remote computer create that username and password with the same as the username you are logging onto.  Have you tried to dupicate your username/password on the remote domain Active Directory rather than just on the local computer.  

I guess you could always also just create a batch file with your above code in it and place it on your computers startup folder to auto net use it when you log on?
vguzmanIT ManagerAuthor Commented:
That's what I am doing right now using the net use command but I was looking for a different way on how to do it.  Do you have any other ideas ??
2hypeCommented:
What is wrong with the batch file method you are using?  I wonder if you enabled the guest account.  Gave the folder permission to the guest account you are sharing.

You could try the following

GO to start run -- gpedit.msc -- Windows settings -- Security Settings -- local policies -- security options --
FInd
Network Access:  Let everyone permission apply to anonymous users -- set to enable
Network Access:  Shares that can be accessed anonymously - add the share name

Now give everyone rights to the folder you are sharing.

He should now not be prompted for a username and password but anyone can connect to that share even without knowing any credentials.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.