?
Solved

Installing Two VWIC2-2MFT cards in Cisco 2821 to combine four T1 lines

Posted on 2008-11-13
25
Medium Priority
?
1,408 Views
Last Modified: 2012-05-05
We just purchased a CISCO 2821 router so we can upgrade our Internet connection in our office.  We also purchased two VWIC2-2MFT cards to plug into the router.  The issue we are having is coming up with the correct code to get the cards recognized and to have them combine the four T1 lines into one.  Any code help would be greatly appreciated.  
0
Comment
Question by:danaustri
  • 11
  • 9
  • 5
25 Comments
 
LVL 7

Expert Comment

by:dkarpekin
ID: 22952194
To recodnie the card , you'll need live connection......connecting them both by "reverse T1" cable , might do the trick.
Combine them into one, you should posted topology connection with IP involved.
A lot info , how do so , you can find on Cisco support, there is a lot of info how do all variations......After choosing your scenario, you can preconfigure, as it will be advised, adn than posted here , if still have more questions.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22952209
Here is an example config:

Once you enter the card type command, you should see controller config.  Once you define channel-groups on the controllers, you should see serial interfaces:

card type t1 0 0
card type t1 0 1
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1

interface Multilink1
 ip address x.x.x.x 255.255.255.252
 ppp multilink
 ppp multilink group 1
0
 

Author Comment

by:danaustri
ID: 22952904
JFrederick29, thanks for the response.  I am assuming the x.x.x.x, I plug in the gateway ip address the isp provided me, is that correct?  Also, do I have to set a ip address for the serial connections?
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 

Author Comment

by:danaustri
ID: 22952921
Also, the subnet mask after the x.x.x.x, I am assuming that is the subnet mask that is provided by the isp, correct?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22952922
Nope, the only IP address which yes, is provided by your ISP is configured on the Multilink interface.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22952925
Yes again on the subnet mask.
0
 

Author Comment

by:danaustri
ID: 22953194
Do or would I need to use the following commands:
network-clock-participate wic 0
network-clock-participate wic 1
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22953290
Those I believe are specific to voice so if this is purely a data T1 bundle, you don't need to use them.
0
 

Author Comment

by:danaustri
ID: 22959892
So I think the router is programmed correctly but I am having a logical issue with the ip addresses.  For theory's sake, Here are the addresses(not the actual ones) that were provided from the ISP and the ip address for my router.  The issue I am having is setting up my computer to get onto the internet from the router with the correct ip address, subnet, and dns servers.  I need to know what I need to set my computer to or what I need to change on the router.  Basically I have the gateway ip address and then my external static ip address that I am trying to use on the computer that I want to get on the internet.  I know this is probably very trivial but somewhere I am messing up the ip addresses.  Any help would be greatly appreciated.

ISP Provided
Primary DNS:  1.2.2.1
Secondary DNS:  1.2.4.1
gateway:  90.92.93.94
subnet mask:  255.255.255.240
Comments:  I have set the router to use the DNS's listed above and the gateway address and subnet per the previous email string.
External Static Ip address for computer I am trying to connect:  90.92.93.95

Router Information:
router IP address:  192.168.0.1
subnet:  255.255.255.0

Final question, what should the following be on my computer or what do I need to change on the router to get out onto the internet correctly?
Computer Information
Ip Address:  ?
Subnet Mask: ?
Default Gateway: ?
Primary DNS: ?
Secondary DNS: ?
0
 
LVL 7

Expert Comment

by:dkarpekin
ID: 22960049
You should use 192.168.0.0 on production, it is ment for homy networks.
It is limited by IP's per subnet, and can you give eventually "strange" problem -like have communication between subnets, when it is not suppose to be ...and so on.
Considere use 172.16.0.0/16 or 10.10.0.0/16  they will give 65K adreeses, wich you can use by logical blocks, will simplify mangment , security , access seperation resources distribution.
Draw copnnecion diagram will help also on any further recomendation......
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22960084
So, you have 90.92.93.95 assigned to the router multilink interface, correct?

You also setup NAT?

int g0/0 <-- or whatever interface with 192.168.0.1
ip add 192.168.0.1 255.255.255.0
ip nat inside

int multilink1
ip add 90.92.93.95 255.255.255.240
ip nat outside

access-list 1 permit 192.168.0.0 0.0.0.255

ip nat inside source list 1 interface multilink1 overload

You also have a default route?

ip route 0.0.0.0 0.0.0.0 90.92.93.94

For the PC:

Ip Address:  192.168.0.10   <--for example (192.168.0.x)
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1
Primary DNS: 1.2.2.1
Secondary DNS: 1.2.4.1
0
 
LVL 7

Expert Comment

by:dkarpekin
ID: 22960207
He still need NAT...
But it is confusing still , how exctly he was intend to use two T1's?- does he have two ISP each per T1? With out toplogy/connection diagram will be difficult do "guees" work
Load balancing is a technique to spread work between two or more computers, network links, CPUs, hard drives, or other resources, in order to get optimal resource utilization, throughput, or response time.
http://en.wikipedia.org/wiki/Load_balancing_%28computing%29

From a networking standpoint, there are at leasy 3 different features that use load balancing:

1. Server Load Balancing - Typically used in a 'server farm'. Think of google.com 's web servers, all the web requests coming in from the internet are distributed amongst hundred of servers.

2. ISP or Internet Load Balancing - Many companies have multiple internet connections.

3. Link Aggregation (LACP) - Multiple physical links between 2 network devices, typically used to increase backbone bandwidth.

These are 3 distinctly different implementations of Load Balancing that require different network capabilities and features.

That's why it's difficult to answer your question without knowing what you are trying to accomplish.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22960249
He is doing MLPPP to aggregate the four T1's into a 6Mbps link to his ISP which I assume has been coordinated with the ISP .  By nature, MLPPP would be with a single ISP.
0
 
LVL 7

Expert Comment

by:dkarpekin
ID: 22960352
Then he just need add NAT(but have confirm with ISP , if does requare one), and preferebly switch to 172.16.x.x or 10.x.x.x  Simplify config, he should use SDM, just add
name(config)#ip http server
0
 

Author Comment

by:danaustri
ID: 22961075

int multilink1
ip add 90.92.93.95 255.255.255.240
ip nat outside


We were able to get online via a laptop by adding ACL rules and the other access-list and NAT rules you mentioned above

However, in the code snippet above, we're using up one of our 5 static IP addresses to assign to the Multilink interface. Is there a way to not do this? We need to be able to use all 5 static IPs in the future. Is this possible?
0
 
LVL 7

Expert Comment

by:dkarpekin
ID: 22961107
You can use them for diffrent purposes-
#1 IP - current internet access
#2 IP- VPN access
#3 IP - DMZ/server farm
and so on.......
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22961131
However, in the code snippet above, we're using up one of our 5 static IP addresses to assign to the Multilink interface. Is there a way to not do this? We need to be able to use all 5 static IPs in the future. Is this possible?

No, you need to use one on the Interface.  What you can do is "port forward" ports using that IP address so you can still use it for inbound connections.
0
 

Author Comment

by:danaustri
ID: 22961619
Ok so here is what we did:

Multilink1 is now assigned the default gateway address for the office. We then  issued the command

ip route 0.0.0.0 0.0.0.0 Multilink1

the question is what to do with the G0/0 interface...  Let me explain the topology a little more:

one of the remaining static IPs is assigned to a Windows Server 2003 machine that is then acting as a DHCP server for the terminals in the office.  Since we have assigned the G0/0 interface an IP of 192.168.0.1 (which is then plugged into a switch) how can the Windows Server 2003 machine keep its static IP and reach the internet through G0/0

example:

default gateway:  90.92.93.94   <----Multilink1
subnet mask:  255.255.255.240

g0/0 is 192.168.0.1
subnet mask: 255.255.255.0

Windows Server 2003:
IP:90.92.93.95
subnet mask: 255.255.255.240
Default gateway: 90.92.93.94

Again, how can the 2821 be setup so that the Server2003 machine can keep its static IP? can we turn g0/0 into some sort of dump pipe?  Sorry for the crude terminology

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22961669
You want the Windows 2003 server to be accessible to the Internet?  Or are there certain services that it is running that you want accessible?  You can do a 1-1 static NAT for the server so it will have a real IP in the 192.168.0.0/24 subnet but will appear to the Internet as 90.92.93.95.

ip nat inside source static 192.168.0.x 90.92.93.95  <---where 192.168.0.x is the IP of the server

You can use an access-list inbound on the multilink interface to restrict port access to the server if desired.
0
 

Author Comment

by:danaustri
ID: 22961886
Yes, we need the Windows 2003 Server to get to the internet. Its only function is as a DHCP server for the internet machines in the office.  We made the change but it did not work however we were able to ping Multilink1 (a.b.c.129)

Here is the config file for the router. thanks for all your help so far:

Building configuration...

Current configuration : 4229 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
card type t1 0 1
card type t1 0 3
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$WFyK$CDrh7ss9fSjGfXMF5Gsh/0
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no network-clock-participate wic 1
no network-clock-participate wic 3
ip subnet-zero
no ip source-route
ip tcp synwait-time 10
!
!
ip cef
!
!
no ip bootp server
ip domain name yourdomain.com
ip name-server 209.116.241.10
ip name-server 216.99.225.31
!
username routername privilege 15 secret 5 **password cyphertext**
!
!
controller T1 0/1/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/1/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/3/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/3/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
!
interface Multilink1
 ip address a.b.c.129 255.255.255.248
 ip access-group 100 in
 ip access-group 101 out
 ip nat outside
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface GigabitEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
 ip address 192.168.0.1 255.255.255.0
 ip access-group 100 in
 ip access-group 101 out
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface GigabitEthernet0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no mop enabled
!
interface Serial0/1/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Multilink1 overload
ip nat inside source static 192.168.0.1 a.b.c.130
!
logging trap debugging
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 remark inbound
access-list 100 remark SDM_ACL Category=1
access-list 100 remark inbound
access-list 100 permit ip any any
access-list 101 remark outbound
access-list 101 remark SDM_ACL Category=1
access-list 101 permit ip any any
no cdp run
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
 
Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for  one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.
 
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
 
username  privilege 15 secret 0
 
Replace  and  with the username and password you want to
use.
 
-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22961926
>ip nat inside source static 192.168.0.1 a.b.c.130

conf t
no ip nat inside source static 192.168.0.1 a.b.c.130
ip nat inside source static 192.168.0.100 a.b.c.130  <--server IP

This can't be .1 which is the router interface.  It should be the 192.168.0.x address assigned to the server.

When you say the server needs to access the Internet.  It will be able to along with all other machines as long as it is assigned a 192.168.0.x address.  It will appear to the Internet as a.b.c.129.  Will it be accepting incoming connections also?  If not, you don't need to assign it a different static NAT unless you want it to appear to the Internet as a.b.c.130 instead of .129 or people will be accessing it directly from the Internet.
0
 

Author Comment

by:danaustri
ID: 22962296
Sorry, one detail: we are not able to ping Multilink1 from the Server 2003 machine.  We thought we were able to but we accidentely still had the old router plugged into the switch.  

We made the change but didnt work even with the corrected 192.168.0.3 ip address.  We thought that maybe it was because the subnet masks werent the same between the router interface IP and the Server 2003 IP (255.255.255.0 and 255.255.255.248) so i changed that for Gigabitethernet0/0.  Help please, we are so close!!!
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22962311
The router interface and Server should have the same subnet mask (255.255.255.0).  The server should also have a default gateway of 192.168.0.1.  Is the gateway correct?
0
 

Author Comment

by:danaustri
ID: 22962636
Ok.  we got it working. We were missing one crucial piece of info, the ISP had us use a totally differnent IP address for the Multilink interface.  After that, we could set the Gigabitethernet0/0 interface to be the default gateway IP aaddress so now all the systems running static IPs can now access the interenet and the router through this port. Thanks much for the help JFred
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 22962644
Excellent.  Nice job!
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question