Checkpoint SecureClient - Mac version won't start up

I have been using Checkpoint Securemote as a VPN for years. After installing Leopard 10.5.5 my machine would not start up. I made it a target disk and deleted the folder LaunchDaemons and the machine works ok. But if I install Checkpoint now, the icon does not appear on the taskbar and I get a message "Services not Started, reboot". If I try to start services manually, I get:

Last login: Thu Nov 13 21:41:52 on ttys000
[Platinum:~] Crystal% source /opt/CPsrsc-50/.cshrc
[Platinum:~] Crystal% sudo scc startsc
Password:
Starting SecureClient services...
launchctl start error: No such process
launchctl: Couldn't stat("/Library/LaunchDaemons/SecureClient.plist"): No such file or directory
nothing found to load
Failed to start SecureClient services          
[Platinum:~] Crystal%

On my other Mac where Checkpoint works fine, there is no such file. I tried to create one, but I am told I have insufficient permissions. Is this perhaps a root-administrator-user issue? The install file for Checkpoint on Macs is attached.
Checkpoint-MAC-releaseNotes104.pdf
redjayAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

calltmsCommented:
Is your other Mac running Leopard? Have you checked with CheckPoint to ensure you are running a Leopard compatible version, and that it is the latest version? Did you upgrade your Mac from 10.4 to 10.5, and keep existing software? Sometimes software just needs reinstalled after such a task - I know of several apps that don't like the transition and need reinstalled. I also know of a few apps that were very glitchy in Leopard period and had to wait for a new version to come out (one of those apps finally released the new version in September, 2008 which is ridiculous if you ask me . . .)


Anyway, check all of that and let me know.
0
redjayAuthor Commented:
Hi call - thanks. I just found the solution - hidden in the Checkpoint Release Notes for Mac OS X. It says that if you upgrade you must first uninstall Checkpoint then reinstall. And if you forget, there is a magic way of uninstalling on the command line. I followed all that, and it worked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.