File shares show up when viewing by IP but not hostname

AOSdigital
AOSdigital used Ask the Experts™
on
I have a client who is using the Hamachi VPN software for linking computers in two office locations. For some reason when I try to view the file shares by hostname it will pull up the computer but will not display the actual file shares. When I browse by the IP assigned by hamachi it will display the shares. I have modified the host record to resolve the IP to hostname. One of the computers has a web server that is used by their software and that will display fine by either the hostname or the IP which tell me the name resolution is fine. I just have no idea why the shares will not display when I type the UNC path into the run prompt.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you using a WINS server.  You may need to modify the WINS entries, or just turn it off.

Author

Commented:
There is no WINS server. it is just a basic peer to peer Windows Xp pro network.
Jeff BrownGlobal Helpdesk Supervisor

Commented:
This is a simple dns issue
you will need to manually set dns for these computers
one to the isp or router  depending on how you are configured
the other to the hamachi addres of the other computer. this will enable  them to use host names.

--wild
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Author

Commented:
They are both running hamachi so modifying the host record should work fine, right? I have done it this way in 10+ locations. How do I manually set up the DNS?
I don't think this is a DNS issue.

AOSdigital - run a pint -a against the IP address to test for a DNS issue.

In the past I've seen a server showing a no shares if the user had file syncing turned on.  You don't have file synchronization turned on do you?

Author

Commented:
I ran the ping -a and it resolved the Ip to hostname fine. I know it is not dns because I can access the web server that is on that machine by IP and it resolves fine. Where is the file sync? I can't remember.
in MS Explorer > Tools > Folder options > Offline Files tab.

Author

Commented:
This is the screen shot of the offline files tab. One thing I forgot to mention is this computer is used for an N-Computing server. I don't think this is an issue but who knows.
Screen-Shot.doc
No it shouldn't be an issue and clearly your offline files are turned off.

Go to the properties of your Nic then the properties of TCP/IP, under the WINS tab you'll see information about LMHOSTS lookup and NetBIOS settings.  Turn off LMHosts lookup and Disable NetBIOS over TCP/IP.  Then reboot and retest.

Author

Commented:
I got it now. Thanks for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial