Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

UPNP Problems between PS3 and PC Using WMP11

Posted on 2008-11-13
6
Medium Priority
?
2,499 Views
Last Modified: 2013-12-26
Hi there,
I'm trying to use WMP11 as a media server for my PS3.  The PS3 will pick up my laptop (XP/SP2) as a media server using WMP11 fine.  The PS3 used to pick up my old pc (XP/SP2) using WMP11 fine as well but that PC has some issues where it was freezing.  I ended up rebuilding it and re-installing the OS.  I installed XP as I was using on the previous build and I used SP3.  I got everything rebuilt and working nicely so I could have a media server for my PS3 and then when I tried it the PS3 wouldn't find it.  Annoying as I spent the last week doing all this!  
I've tried just about everthing I can think of to get it working.  Disabled windows firewall, checked the router and can see both the PS3 and PC are connected and listed as active.  I even rolled back to SP2 in case the problem lay there.  I re-installed WMP11 about 3 times because I was having problems where it was maxing out the cpu.  Solved by deleting everything from the library but re-installed anyway.  I've checked that all the correct services are running and they seem to be.  

Please can anyone suggest anything I might not of thought of.  I would be most grateful as I've spent so long setting this up and am out of ideas!  thanks
0
Comment
Question by:gonzo1978
  • 3
  • 2
6 Comments
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 22955525
Having just told someone that you can't do this with the PS3 without using something like Orb I'm just checking if you were able to stream OK with your SP2 or if the devices just detected each other's presence?
0
 
LVL 10

Expert Comment

by:Jstncase
ID: 22956527
Odd, I currently have this working with my PS3 and XP computer at the moment. Under WMP11 I would make sure under sharing library that you have the PS3 authorized or set it to any device can view the files. On my PS3 the computer will not be found immediately either. For some reason I have to have WMP11 running on the computer for a few minutes before the PS3 will find it. I also found that when I ran it as administrator and not my own account (yes my account is an admin) it would work better.

On my Ps3 once it finds it, it would show up as WMP11-<UserName> so in my case it would say WMP11-Jstncase.
0
 

Author Comment

by:gonzo1978
ID: 22958022
Hi,  Thanks both for replying so quickly.
MASQUERAID - it used to work fine without "orb" and using xp sp2 wmp11.

Jstncase - I have tried setting the sharing library to "any device can view the files" but it never picks up any devices.  I guess this means that the pc is at fault because it's not discovering the ps3?  I used to have to have wmp running on the pc when it worked previously on the old pc build aswell but strangely my laptop doesn't need wmp running.  I will try running the pc as administrator.  thanks for that tip.  Am on way to work now so will be tonight.  Could this possibly have anything to do with the account that the  SSDP discovery service runs under?  Not sure what accout it is on my pc but it runs under "NT AUTHORITY\LocalService" on my laptop?

Thanks for your help :)
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
LVL 10

Assisted Solution

by:Jstncase
Jstncase earned 1000 total points
ID: 22960653
You should not have to have WMP running, this is supposed to run as a service in the background, and yes the NT Authority\Localservice is fine. Just sometimes actually keeping WMP open would help.

Otherwise, lets talk/think/work through a couple steps. Sorry if it sounds redundant or if you did it already.

From your PS3 Confirm under Network Settings, "Media Server Connection" is enabled
From your PC can you ping your PS3
WMP11 has been reinstalled or latest updates applied
WMP11 is allowing the device (PS3)
Firewall is temporarily turned off for this testing
PS3 Dashboard has been updated
If possible from another device/machine you can browse your music library through WMP11
Your PC and your PS3 are on the same Subnet

Last thing I just did/checked on my system, I restarted the "Windows Media Player Network Sharing Service" and confirmed it was running again.
From my PS3 I waited about 2 minutes then did "Search for Media Servers"
0
 

Author Comment

by:gonzo1978
ID: 22963314
-Media server is enabled.
-can ping PS3 from PC
-WM11 has been re-installed and is patched with updates.
-I can't allow the device on WMP11 because it doesn't show up in the media sharing window.  With my laptop I get an icon for "unknown device" which is then allowed but there is nothing with the PC.
-Firewall is turned off
-I downloaded the latest system update for the PS3 a couple of nights ago.
-I don't think I can browse to the PC media library from my laptop although I'm not sure exactly how to do it?
-All devices have subnet mask 255.255.255.0 (is this what you mean by subnet?) sorry my networking is a bit weak.
-I have restarted the "Windows Media Player Network Sharing Service" and confirmed it was running again but the PS3 won't pick it up.

I have media sharing back on my laptop (i'd turned it off for testing before because I thought it might be interfering) and the laptop connects fine.  The "unkown device" icon showing WMP sharing window.

I was looking at my router and noticed something strange. It shows all 3 machines attached (PC,PS3 & Laptop) but on the Upnp page it only shows the PC and PS3 and not the laptop.  This is strange as the laptop is working?  I've attaced a file with some screen shots if they help.
PC is 192.168.1.2
PS3 is 192.168.1.3
LT is  192.168.1.4
The Upnp page shows 1 line for UDP from the PS3, 1 line for UDP from the PC and 1 line for TCP from the PC but nothing for the laptop???  Looking at this I would have thought the problem would be reversed and the laptop would not connect to the PS3.  As I say my networking is quite weak so maybe I've got this all wrong.  Does this help at all?

Thanks again




router-screenshots.doc
0
 

Accepted Solution

by:
gonzo1978 earned 0 total points
ID: 22964557
At last I've figured this out!!!
It's really been bugging me but now I can rest easy...

For anyone else who has a this problem here is the solution:

I think there were two related issues that I had to fix.  I noticed an error in the sytem event log as follows:

WMPNetworkSvc
"A new media server was not initialized because WMCreateDeviceRegistration() encountered error '0xc00d2782'. The Windows Media DRM components on your computer might be corrupted. Verify that protected files play correctly in Windows Media Player, and then restart the WMPNetworkSvc service."

I restarted the service and the error occurred again.  I googled and found a guy had the same problem trying to get his Kodac device working with WMP11.  He said the error meant the service wasn't really running even though it showed as running in the service console.

He gave a link to an update that was supposed to fix this problem.  I'll give you a link to his thread page but don't use his update link  it because it doesn't work:
http://forums.techarena.in/media-player/873213.htm

He said you needed IE to use the fix from the link and when I tried in ie6 (yes I hadn't updated it yet since re-installing my OS) it didn't work.  So I went to windows update to get ie7 thinking I must need that.  I did a full search for all updates for my PC and realised that there were loads missing including a couple for WMP11 (yes I made a mistake in the prevous post when I said I had all updates). I thought I did but that was because nothing was coming through automatic updates (for some reason it wasn't working since I did a ghost restore the other day).  Anyway I updated everything inclduding WMP11 runtime 9.5 and a WMP11 security update.  Once I'd restarted I tried a stop/start of the service again.  The error no longer appeared in the system event log so I thought "yippee!" I've fixed it.  Nope.  Still not working.  I tried that guys link and that didn't work in ie7 either.  So I googled again and found this:

http://support.microsoft.com/kb/891664

Basically I read through a bit and it's all about licencing of media in your WMP.  Digital Rights Management (DRM).  In the registry (HKEY_LOCAL_MACHINE\Software\Microsoft\DRM\DataPath) there is a binary value pointing to a hidden system folder that holds information about your Digital Rights Management.  The data path should be pointing to  "windows install drive\Documents and Settings\All Users\DRM".  Mine was pointing to F:\Documents and Settings\All Users\DRM.  Only problem being that when I rebuild my pc I changed my windows install drive letter to "C" and there is now only data on "F".
I guess this data must be help by MS and when you download WMP again it gets put back in your registry.  Would have been fine if my main HDD was still F!

I changed the path to use "C" and restarted the service and it immediately picked up my PS3!  Woohoo!  

Sorry if this is a bit of a rant but am really pleased I've found a solution because I've spent a lot of time on this.  I hope this saves someone else the effort.

Thanks to the guys who tried to help me out on this.
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, in one of the tech-blogs I usually read, I saw a post about the best-selling video games through history. The first place in the list is for the classic, extremely addictive Tetris. Well, a long time ago, in a galaxy far far away, I was…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses
Course of the Month14 days, 17 hours left to enroll

577 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question