Can't boot to OS on Dell Power Edge, 4400, Raid issues

Story: we've received these state of the art systems *cough* and have to try to put them on our network. They apparently booted up fine last week, now i have a guy on site and they are not booting at al.

Boot up
F2 setup, F11 Utility
133 mhz L2 cache 256 kb

Press ControlA - SCSI Select Util

SCSI ID: 5 NEC CD_ROM Drive 466 20.0
Power Edge Expandable Raid Controler BIOS Oct 22 1999

Press Control M to Run configuration utility

HA-0 (Bus 8 Dev 8) Type: Perc 2/dc sta fw 1.01 dram/28 mb
battery module is present on adapter
0 logical drives found on the host adapter
0 logical drives handled by bios

Strike F1 to retry boot, F2 for setup utility



Information found in bios
BIOS Version A0
diskette Drive A 3.5 inch 1.44 MB
Diskette Drive B ------ Not installed
Primary SCSI-------On
Channel A------- SCSI
Channel B ------ SCSI
Secondary SCSI ---- On


I have like 0 knowledge of RAID

appreciate any help troubleshooting.
LVL 5
funnymanmikeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dfxdeimosCommented:
This looks like the RAID controller is detecting no disks attached to it as indicated by:

"0 logical drives found on the host adapter"

I assume this came with hard drive and an OS installed?
0
funnymanmikeAuthor Commented:
yeah there are hard drives and there was a OS

i am working with the onsite guy to kind of go through the screens, i will continue to post screenshots of our progress
TroubleShooting-654pm.jpg
0
dfxdeimosCommented:
Can you open up the side of the computer and verify the physical connections to the drives from the controller card? Can you verify the power connections? Can you verify that when you turn the server on that the drives spin up and appear to be functioning in that manner?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

funnymanmikeAuthor Commented:
We are powering down to confirm existance of HD

attached is updated guide.
TroubleShooting-754pm.jpg
0
funnymanmikeAuthor Commented:
7 drives confirmed plugged in
they spin on power up
0
dfxdeimosCommented:
Ok....

1) Can you remove a drive an put it in another system to verify that it is good?
2) Can you determine via the #s on the hard drive if they are all from the same batch?

I think the controller card they are plugged into is the likely problem. You have looked in the BIOS and the controller BIOS just to verify that all the settings look correct? You could go to the contoller manufacturer website and get a bootable firmware update for it and see if a firmware update will bring it back to life.
0
funnymanmikeAuthor Commented:
at this tine we are unable to remove disks
i don't want to start doing something and put the system deeper in the craper

as you can see from the lattest troubleshooting, all the HD's were ready, we put them in a online state, and when rebooted, the SCSI menu saw the logical disk, but however still did not boot into the OS


TroubleShooting-910pm.jpg
0
dfxdeimosCommented:
So it sees a logical drive now. If you use some sort of boot disk (Bart / Win PE, Live Linux, etc) can you see any sort of structure on the logical volume?
0
dmbgoCommented:
Hi Mike,
Its David here, I have spent quite a bit of time working on PE4400s in the past, now that you have put the disks online and the HBA (raid controller) has recognized the logical drive it may just be a matter of making the raid controller first in the boot order in the bios.
To do this you would need to press F2 at startup and enter the BIOS setup - or have you already done this?
0
funnymanmikeAuthor Commented:
we tried this shortly after, then the screen stays at a cursor blinking screen.

Not sure when i get can this guy on site again next.
0
dfxdeimosCommented:
As I said in my previous comment, you should try to boot from a live cd and see if you see any files ont he logical disk. If not, then I would say that your controller card took a crap and destroyed your volume. In either case, I would press (if time isn't a major factor) for Dell to either replace the system or the card & hard drives.

Personally, it makes me very suspect when hardware starts failing immediately before its even been put through its paces.
0
dmbgoCommented:
The cursor blinking screen suggests a corrupted boot sector. Try booting from a windows CD, you may be able to do an in place upgrade if the partition is still recognizable by windows. I dont think you mentioned the Operating system version. Also, what happened between "booting up fine" and "not booting at all" ?
Let me know if you need mor info on recovering using the windows CD
Cheers
Dave
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
funnymanmikeAuthor Commented:
we were not able to get to the OS. we 'think' its windows 2003 server. but will have to wait and see. problem is. don't you need to do some special boot proces in order for windows install cd's to see your scsi drives?
0
dfxdeimosCommented:
It depends. If you use something like Knoppix it has built in device support for many common SCSI / SAS RAID controllers.

http://www.knopper.net/knoppix/index-en.html
0
funnymanmikeAuthor Commented:
well idealy i would like to boot into a windows 2003 server install cd.
0
dmbgoCommented:
Nothing very special, you need a w3k server cd and perhaps the perc 2/dc driver disk found here http://support.us.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R15117&formatcnt=1&libid=0&fileid=13471
Although I suspect that windows 3k will natively support this perc.
0
dmbgoCommented:
The procedure is to insert the CD, after setting the bios to boot from CD, then if W3k supports the perc it will just detect it and the install should run.
If W3k Setup doesn't detect the perc, you need to use a driver disk. The drivers I pointed you to are the latest, but they are for W2K and are dated September 2000, well before W3k. Since there are no drivers for W3k I suspect you will find native support on the W3k CD.

Once you get the install up to the partitioning menu stop, unless you want to do a clean install. The setup program should list any previous versions of windows and any partitions on the drive.
0
dmbgoCommented:
If the W3k CD doesn't support the perc download the drivers that I pointed you to boot the w3k cd and press F6 at the first windows setup blue screen where it says press F6 now to install .......
0
funnymanmikeAuthor Commented:
dmbgo:
 That link you gave me is a 45 k file, what am i supposed to do with it?

i don't understand how i can install it, when the system won't boot.


boot1.jpg
bootpriority1.jpg
0
funnymanmikeAuthor Commented:
i can't seem to change anything on this

we've tried entering in the numbers for the drives, but it does not save what we put in.
logicalboot.jpg
0
dmbgoCommented:
Hi,
Your physical drives on the raid controller are normally combined into one logical drive, so I think the preceding screen is saying lun 0, logical drive 0 (lun means logical unit number)

any way back to your question about the driver I linked you to, this is the W2k boot time installation driver for the PERC, but as I said I strongly suspect this driver is built into W3k, so you probably dont need it.
I am going to ask some questions here so that I am sure of what we are trying to and can achieve.
Do you have a W3k cd and is it the same one that is installed on the system?
Is there any reason why we cant do a fresh install, or do you need to recover data from the system?
Have you tried booting from the w3k cd and if so what happened?
0
funnymanmikeAuthor Commented:
we are trying to do a fresh install
however the system is not booting to the CD rom, it is a official w2k3 cd, not a backup.
0
dmbgoCommented:
Your screen shot boot 1.jpg shows a numger of logical drives is it 0 or 1? It is not clear from the photo.
Also you have the boot order correct to boot from the CD, so is the cdrom drive trying to read the cd after the Perc bios finishes initializing? You should get a "press any key to boot from the cd" prompt.
If you are not getting this you may have a faulty CD drive, or a damaged CD.
You said "systems" in your initial problem description, are you able to swap the CD from another system?
Cheers
Dave
0
funnymanmikeAuthor Commented:
dmbgo
boot1.jpg i have askd the guy on site, however he said no numbers appear after he moves the screen around, i will try again Wednesday.

correct, we should get "press any key to boot from the cd" but are not, boot1.jpg shows exactly where the system stops

surprisingly the other system does not have a CD rom device,
0
dmbgoCommented:
it wouldn't just say "logical drives found on host adapter" "logical drives handled by bios" it will be saying either "0 logical drives found on host adapter" "0 logical drives handled by bios" or perhaps "1 logical drives found on host adapter" "1 logical drives handled by bios"
You could try removing the perc from the system all together and see if it tries to boot from CD then, this wont fix anything, but if it tries to boot from CD it will tell us that the Perc is not initialising properly and is hanging the boot sequence.
If the latter turns out to be true I would then delete all logical drives on the perc, and reinitialise the drives. This will remove any corrupted boot sector / partitions from the drive array and should enable us to finally install windows
0
dmbgoCommented:
Hi,
Just wondering how you went?
0
funnymanmikeAuthor Commented:
dmbgo:

Sorry for the delay, we never continued with it. it was old technology the owner got for free. he is currently pricing out new equipment for his needs.

Just not sure how to handle this case since the issue still exists.
0
dmbgoCommented:
You can either close the question and award some points for trying, or request that the question be deleted and no points awarded, I think you should give me some points for being so helpful, we would have fixed it in the end :)
Cheers and best wishes
 
David
0
funnymanmikeAuthor Commented:
Thought i feel dfxdeimos's help was in the wrong area, he still helped. Thanks to dmbgo for providing the excellent help.
Reasons on my grade
Good - beacuse issues was not resolved but everyone continued to post to help
Complete - No - never fixed the issue
Accurate - Partially - i felt we got off track with using alternate os's to boot, and removing hardware
easy to understand - partially - more of an issue with me because of my lack of understanding of how to configure and use RAID.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.