[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Configure Cisco 2611 to work with non DSL modem using a static outside IP address

Posted on 2008-11-13
7
Medium Priority
?
798 Views
Last Modified: 2012-05-05
Hi,
My background:
* New to the networking world
* I have used Cisco IOS and can get around pretty good
* I understand IP addressing
* Some filed experience

Ok, here's what I have.

Cisco 2611 with 10/100 BASE E 0/0 & E 0/1 Ethernet interfaces
Cisco Catalys 3500XL 48 port switch
Westell DSL modem issued by AT&T

I pretty much have a good understanding of how to configure the switch but am having problems configuring the router to access and route out to the internet. I have a statice IP address that was issued from AT&T that I need to use becuase I am hosting a Apache Web server.

If anyone can guide me step-by step, how to configure my Cisco 2611 router with a non Cisco DSL modem using a statice outside IP address, I would be very greatful. Thank you

Flintstonephilly
0
Comment
Question by:flintstonephilly
  • 3
  • 2
  • 2
7 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 1000 total points
ID: 22968183
From config mode, the following commands should give you an idea what needs to be done.

hostname Router1
enable secret <password>
int e0/0
 description internet connection
 ip adddress <address> <mask>
 ip nat outside
 no shutdown
int e0/1
 description LAN connection
 ip adddress 192.168.1.1 255.255.255.0
 ip nat inside
 no shutdown
ip route 0.0.0.0 0.0.0.0 <ISP next hop address>
ip nat inside source list 1 int e0/0 overload
access-list 1 permit 192.168.1.0 0.0.0.255
line vty 0 4
 password <password>
 login
 access-class 1 in
end

Open in new window

0
 

Expert Comment

by:p0sreed
ID: 22974632
please, explain the line no 13

ip route 0.0.0.0 0.0.0.0 <ISP next hop address>
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22974738
This is the default route. The destination that the router will send traffic that it does not have a route for.

http://en.wikipedia.org/wiki/Default_route

0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 

Author Comment

by:flintstonephilly
ID: 22974948
Hi donjohnston,

Thank you very much. I actually had most of the configuration the way you explained except that I did not have line 13 the next hop or the ISP default gateway. Thanks. However, there my be one other issue. In order to use the statice IP address that AT&T gave me, I had to bridge my DSL modem which also ment that I needed to provide the PPPoE information in the router (username and password). I know how to do this with LinkSys and Netgear but not with my 2611. Can you help with this as well?

Thank you again, you've been very helpful.

Flintstonephilly
0
 

Expert Comment

by:p0sreed
ID: 22979973
I have a comcast cable modem and i think i get my IP through DHCP, do i configure my 2611 in this case.

Is <ISP next hop address>, the default router of my ISP that i can see in my linksys wireless router WRT310?

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22980657
0
 

Author Closing Comment

by:flintstonephilly
ID: 31516646
Thank you very much for your comments. They were very helpful.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question