Default NTFS Owner permissions on a newly created folder

We currently have a number of Windows 2003 server. On some of them when you create a folder, it puts the Administrators group of the server as the Owner (This is how we want it)

However on other servers it puts the creator as the owner (This is not how we want it)

Where can I set it so that any new folder that gets created, has the Local Administrators group as the owner?
MattNicholasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
This is usually set on the parent folder. In the folders where they are owned by the creator, you will likely see in the NTFS/security permissions "CREATOR OWNER" with special permissions.

In the parent folder set the administrators group as owners, remove the Creator Owner permissions, and under advanced select replace permissions entries on all child objects....
Your decision, but this is not usually done on the "users" folder for things such as redirected my documents. You can run into problems if you tinker with permissions on those folders.

0
MattNicholasAuthor Commented:
Thanks for that.

But I created the folder on the root of the c:\ so where does it get it's default NTFS settings?

On some servers if you create a folder at the root it sets the Local Administrators group as the owner
However on other servers it puts the creator as the owner and not the Local Administrators group

I understand that I can change the NTFS permissions and replace them, but how do I set it so by default the Local Administators group is the owner at files created off the root?

Cheers,
Darren
0
Rob WilliamsCommented:
The default behavior on an NTFS root should be the creator is the owner. This is why you usually create a folder and make it a share. You can then set permissions on the parent folder and select to apply to child objects.
System drives are different, and the administrators group is the default owner.
You should be able to change the NTFS/Security permissions on the drive itself to affect root inherited permissions.
0
Henrik JohanssonSystems engineerCommented:
Default behavior is that if user is member of administrators group, the owner of the file/folder will be the administrators security group.

This is controlled by the following policy setting:
Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\System Objects: Default owner of objects created by members of the Administrators group
* Administrators group (default)
* Object creator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.