Dual boot CentOS x32 / x64

I am trying to install CentOS 5.2 32-bit and CentOS 5.2 64-bit on the same server.  The server has two pairs of mirrored drives (using Dell PERC 5/i hardware based RAID).  One paired of mirrored drives is labeled sda and the other is labeled sdb.  I have installed the 32-bit version using only sda and vice versa.  I am using the GRUB boot loader.  It doesn't seem to matter what order I install the different version.  Whichever one I install second won't boot.  It will show up on the boot loader menu, but when I select it I receive this error message:

Error 13:  Invalid or unsupported executable format

Can someone please provide some guidance on setting this up properly.

Thanks,
Matt
mtkaiserAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joolsSenior Systems AdministratorCommented:
I'll get the dumb question out the way first;
   Is the server 64bit?

there... thats better...
0
joolsSenior Systems AdministratorCommented:
... now can you post your grub.conf file(s)
0
mtkaiserAuthor Commented:
Yes, the server hardware is 64-bit.  It is a Dell PowerEdge 1900 server.
grub.conf.txt
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

joolsSenior Systems AdministratorCommented:
These two entries arent right are they?


title CentOSx64
      rootnoverify (hd1,0)
      chainloader +1
title CentOSx64b
      rootnoverify (hd1,1)
      chainloader +1
0
mtkaiserAuthor Commented:
I had installed the 64-bit version first on sdb.   Then I started the 32-bit install.  During the GRUB boot loader configuration it said I could add other existing operating systems to the boot menu.  When I clicked add it had a box to put in a name and a pull down menu all of the disk partitions.  From the pull down menu it listed sdb1 /boot and sdb2 VolGroup01.  I wasn't sure which one to select so I added them both to the boot menu.  One I labeled CentOSx64 (for sdb1) and the other CentOSx64b (for sdb2).

When I boot up the server, they are listed on the boot menu.  If I select CentOSx64 it proceeds to a screen that has the following:

rootnoverify (hd1,0)
chainloader +1
Error 13: Invalid or unsupported executable format

If I select CentOSx64b I get the same except it's:

rootnoverify (hd1,1)

So to answer your question, I don't know if those entries are correct, but I know where they came from.

0
chingmdCommented:
You need to change your grub.conf file.     The Chainloader is typically for an OS that doesn't use grub bootloader   Cough... microsoft.

title CentOS (2.6.18-92.el5PAE)
      root (hd0,0)
      kernel /vmlinuz-2.6.18-92.el5PAE ro root=/dev/VolGroup00/LogVol00 rhgb quiet
      initrd /initrd-2.6.18-92.el5PAE.img
title CentOSx64
      root(hd1,0)
      kernel /vmlinuz-2.6.18-92.el5PAE ro root=/dev/VolGroup00/LogVol00 rhgb quiet
      initrd /initrd-2.6.18-92.el5PAE.img


This is assuming that the same kernel and initrd are being used.


BTW:  Unless this is for some special type of testing, the 64 install runs 32 bit binaries perfectly  (I believe that both 32bit libs and 64 bit libs are install)

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joolsSenior Systems AdministratorCommented:
no they are not correct, look at the one for the 32bit OS.

at the grub prompt try typing the following; note <tab> is the TAB key which should list various options)
c
root (hd1<tab> [choose the correct partition number you used for the /boot partition on the 2nd disk] )
kernel /vmlinuz<tab>[choose the correct kernel from the list]  ro root=/dev/VolGroup00/LogVol00 1
initrd /initrd<tab>[choose the corresponding initrd]
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.