Trouble Installing SSL Certificates In IIS7

I am trying to install a certificate from Netsol and every time I try to complete the cert request I get:

CertEnroll:CX509Enrolment:p_InstallResponse: ASN1 bad tag value met. 0x8009310b(ASN: 267)

At one point the cert was in, but I got an error about cert authority, so I attempted to remove and re-install it.
I have had the cert re-issued and the new one does the same error. Much Thanks Gurus
i8yurdogAsked:
Who is Participating?
 
i8yurdogConnect With a Mentor Author Commented:
Here's Microsoft's $300 Solution: I saw him do it, you have to grab the thumb print from the certificate store.

Yes, I  finally had to pay Microsoft for it.

Problem

==========

- CertEnroll::Cx509Enrollment::p_InstallResponse: ASN1 bad tag value met. 0x8009310b while installing a new certificate

 

Resolution

===========

- During the first install the certificate had been placed in the Other Users certificate store

- We moved it to the Local Computers Personal store

- The certificate was missing the private key

- Since the certificate was requested form the same machine we used the following command to recover the private key

Certutil repairstore my certificate thumb print

0
 
Quickdraw6906Commented:
Same problem here. the links by RubalJ did not solve.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.