Looking for simple config for Cisco 1812 Dual Wan

Hi All

I have a cisco 1812 dual wan router and 2 adsl internet connections as follows.

ISP1
Static IP:*.*.159.21
Subnet: 255.255.248.0
Gateway: 87.194.152.1
DNS 87.194.0.51, 87.194.0.52
Unencapsulated Connection

ISP2
Static IP:*.*.250.236
Subnet: 255.255.255.255
Gateway: 217.47.56.73
DNS 62.6.40.162, 194.72.9.38
(Encapsulated - CHAPS - Username and Password Required)

I have 2 wan ports
FastEthernet0
FastEthernet1
8 Switch Ports FastEthernet2 / 9
1 Vlan = Vlan1

What would be a basic config to enable FastEthernet2 to get an internet connection through the router to either ISP via FastEthernet0 or FastEthernet1.

Any help would be greatly appreciated.

Many Thanks
Steve
LVL 19
Stephen MandersonSoftware EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
This is an example NAT and routing config for a dual ISP setup:
                     
ip nat inside source route-map isp1 interface FastEthernet0 overload                          
ip nat inside source route-map isp2 interface FastEthernet1 overload                          

access-list 1 permit 192.168.0.0 0.0.0.255                                      

route-map isp1 permit 10
 match ip address 1
 match interface FastEthernet0

route-map isp2 permit 10
 match ip address 1
 match interface FastEthernet1

ip route 0.0.0.0 0.0.0.0 87.194.152.1
ip route 0.0.0.0 0.0.0.0 217.47.56.73

The equal cost routes allow you to use both providers.  If you want to use one ISP primarily and have the other ISP as a backup, simply add 10 to the end of the less preferred route.
0
Stephen MandersonSoftware EngineerAuthor Commented:
Hi there,
Thanks for the prompt reply, however thats me just getting round to testing :-) I am currently working with ISP 1 on FastEthernet1 just now until I can get everything working with that then will include ISP 2 at a later stage.
I still cannot get access to the web via FE1. I still think I may have an issue with my config as ping google.com source FastEthernet1 times out... (Its an un encapsulated conenction) I know it is up as I could ping last week under a different config.
My testing machine has the following IP details
IP 192.168.0.2
Subnet 255.255.255.0
Gateway 192.168.0.1 ? Is this correct?
DNS 192.168.0.1 ? Unsure of this one.. Does the Cisco use DNS forwarding similarly to MS Server?
Many Thanks
Steve

Building configuration...
 
Current configuration : 1797 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Edge
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$YDs9$aHW/YML0sprOQraYLUWj./
enable password *****
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip routing
!
!
no ip cef
no ip dhcp use vrf connected
!
!
ip name-server 87.194.0.51 ##### ISP 1 DNS 1 #####
ip name-server 87.194.0.52 ##### ISP 1 DNS 2 #####
ip name-server 62.6.40.162 ##### ISP 2 DNS 1 #####
ip name-server 194.72.9.38 ##### ISP 2 DNS 2 #####
no ip ips deny-action ips-interface
!
!
!
username **** privilege 15 password 0 ****
!
!
!
!
!
interface FastEthernet0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1
 description $ETH-WAN$
 ip address *.*.159.31 255.255.248.0
 ip nat outside
 ip virtual-reassembly
 no ip route-cache
 duplex auto
 speed auto
!
interface BRI0
 no ip address
 no ip route-cache
 shutdown
!
interface FastEthernet2
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 shutdown
!
interface FastEthernet5
 shutdown
!
interface FastEthernet6
 shutdown
!
interface FastEthernet7
 shutdown
!
interface FastEthernet8
 shutdown
!
interface FastEthernet9
 shutdown
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
!
ip classless
ip route 0.0.0.0 0.0.0.0 87.194.152.1
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source route-map ISP1 interface FastEthernet1 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
route-map ISP1 permit 10
 match ip address 1
 match interface FastEthernet1
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password ****
 login
!
end

Open in new window

0
JFrederick29Commented:
The config looks good.  DNS on the client should be your ISP's DNS servers (not the router).
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Stephen MandersonSoftware EngineerAuthor Commented:
Thanks :) Updated but still no internet from the client via FastEthernet2 any ideas why I cant ping from source FE1?
0
JFrederick29Commented:
Can you ping 87.194.152.1 from the router?  Can you ping 74.125.95.99 from the router?

From the client, can you ping 192.168.0.1?  Can you ping 74.125.95.99?

From a command prompt on the client, can you do the following:

telnet 74.125.95.99 80
ping www.google.com
0
JFrederick29Commented:
Oh, wait a sec, ip routing is disabled:

conf t
ip routing
ip cef
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Stephen MandersonSoftware EngineerAuthor Commented:
Good man ! Up and running now :-)
Thanks Again
Steve
0
Stephen MandersonSoftware EngineerAuthor Commented:
Excellent help, top man!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.