HP DC 5750 CDROM issue

Posted on 2008-11-14
Last Modified: 2012-05-05
My office uses the HP Compaq dc5750 Small Form Factor PC and we are running into a problem where the CDROM drive intermittently stops working and we will need to use a paper clip to open.

We've tried the following things with no success.

I.  Uninstalled and reinstalled CDROM drive in the device manager.
2.  Update the BIOS to 786E3

These have worked to temporarily solve the problem, but it always reoccurs.  Does anyone have any ideas?
Question by:Sokolaka
    LVL 3

    Expert Comment

    CD Rom is failing.  Replace it.  Spend the $12.
    LVL 13

    Expert Comment

    >> we will need to use a paper clip to open.

    So it looks like the CD Rom get stuck while trying to open it. If you still can open / read / run the CD after using the paper clip push into the small whole to open the CD Rom, then what can i say is partially of the CD Rom is damage (cover / rollers use to pull out the CD Rom) but not 100% damage as it is still functioning to read / run the CD ...... If you still feel not good to be use, then replace another CD Rom will be the last way to go ..... Good Luck !!
    LVL 33

    Expert Comment

    It might be the OS or your burning software locking the drive
    Does it eject if you right-click the drive in My Computer or the burning software?

    Author Comment

    I'm sorry for not responding sooner.  None of the answers solved my problem.  It's not a matter of swapping CDROM drives (I'm in an office and we have lots of available drives, but it's just a quick fix until it happens again and it's not the CDROM drive malfunctioning.)  The paper clip option I'm aware of, and it's only useful to remove CDs.

    I do not receive a response from the drive if I right click it and try to eject under MY Computer.  I believe it has something to do with the Firmware of the DC5750, CD ROM Drive and Windows XP (or our image).  If I removed the drive from the device manager and reinstall it, it will work for for a little while until it happens again.  I'm not sure if anyone has experienced this same issue with DC5750.  Not all of the users in  our office has this problem, but it does occur sporadically, approximately 5% of our user base has an issues with their drive.  

    I've updated the BIOS on the board with no success and don't where this problem stems from.  As for now we're just doing quick fixes.  I hope that shines more light on our problem.

    Thanks for everyone's input.
    LVL 33

    Accepted Solution

    WinXP frequently has a problem with the existence of "upper and lower filters" which renders the drive inoperable:;en-us;314060  Getting rid of it in the registry is the fix.

    Open regedit and find the following key:  
    Right click in the upper and lower filter entries in these keys and press delete.
    Reboot and check if it is OK now.  

    Or download this and run it:
    LVL 13

    Expert Comment

    >> approximately 5% of our user base has an issues with their drive.  

    If there is about 5% of the user, looks like the image have some issue with that ..... try run the image from the known good condition / without this issue then deploy to those machines having the problem and see whether it solve the problems out .... it not, looks like the hardware issue .....
    LVL 33

    Expert Comment

    Thank you much.    : )

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Suggested Solutions

    This article is a cursory discussion of Intel SpeedStep Technology (SpeedStep) and Enhanced Intel SpeedStep Technology (EIST).  The goal is more to illuminate what these technologies are and are not.  The detail of how each technology works is not a…
    This article may be useful for troubleshooting your PC. Power Supply - no lights or fans running If you have no lights or fans running then either you power is bad, turned off (check switch) or the power supply needs to be replaced. That's a r…
    The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
    The viewer will learn how to download, install and use CrashPlan from on Windows 8. Open your browser and go to Click get started, it’s free then Click the Download CrashPlan button: Click save in Internet Explorer, the…

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now