SSIS Package wont add rows when it runs from the Agent

I'm having an issue with a SSIS package i just created.  This package is simply designed to add rows to a few tables and it runs fine.  when i run the package manually it works.  When i run it from integration services within management studio it works.  when i run it using the agent it runs succesfully but no rows are added to the tables.  What am i doing wrong?  Any help would be greatly appreciated.  Thanks in advance.
thecruzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HoggZillaCommented:
How do you have the package saved, to the File System or SQL Server?
What Package Protection Level did you choose?
You have it in a SQL Server Agent job. What account is it running in under the SSA? If you check the "View History", what is the message. Please copy and paste here. Thanks.
0
thecruzAuthor Commented:
Thanks for the reply.  i'm using File System and the protection level is DontSaveSensitive.  The job is running under my credentials using a proxy.  There is no error messages in the history.  it says it ran succesfully.  That is what i dont understand.
0
HoggZillaCommented:
In cases like this I like to see the log. In the SSIS package, enable logging to a file. See the instructions below. Then post that file here. Please also post the complete history message. Thanks.
http://msdn.microsoft.com/en-us/library/ms138020.aspx 
 
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

thecruzAuthor Commented:
Is this what you are looking for?

Name: PackageStart
Operator: AME\rsmith
Source Name: Package
Source GUID: {0D4B0ACA-03C0-42DB-AF14-DE2AE8046482}
Execution GUID: {FDF8A592-4E6E-4BC1-AC51-1E722DFC21AE}
Start Time: 11/17/2008 12:34:18 PM
End Time: 11/17/2008 12:34:18 PM

Beginning of package execution.
0
thecruzAuthor Commented:
here is the log file
Log.log
0
HoggZillaCommented:
That log only relates to a job, ImportCSV. Is that this job?
On the View History window, expand the last run attempt and highlight the expanded row. What is the complete text in that message.
0
thecruzAuthor Commented:
Yes.  That is the name of package.

11/14/2008 14:09:49,ImportCSV,Unknown,1,BWTCSQLPR01,ImportCSV,One,,Executed as user: AME\RSMITH. Microsoft (R) SQL Server Execute Package Utility  Version 9.00.3042.00 for 32-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    Started:  2:09:49 PM  DTExec: The package execution returned DTSER_SUCCESS (0).  Started:  2:09:49 PM  Finished: 2:09:53 PM  Elapsed:  4.016 seconds.  The package executed successfully.  The step succeeded.,00:00:05,0,0,,,,0
0
HoggZillaCommented:
Please copy the History message. Thanks.

job-history.bmp
0
thecruzAuthor Commented:
sorry about that.  i'm still trying to get used to SSIS.

Date            11/14/2008 2:09:49 PM
Log            Job History (ImportCSV)

Step ID            1
Server            BWTCSQLPR01
Job Name            ImportCSV
Step Name            One
Duration            00:00:05
Sql Severity            0
Sql Message ID            0
Operator Emailed            
Operator Net sent            
Operator Paged            
Retries Attempted            0

Message
Executed as user: AME\RSMITH. Microsoft (R) SQL Server Execute Package Utility  Version 9.00.3042.00 for 32-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    Started:  2:09:49 PM  DTExec: The package execution returned DTSER_SUCCESS (0).  Started:  2:09:49 PM  Finished: 2:09:53 PM  Elapsed:  4.016 seconds.  The package executed successfully.  The step succeeded.
0
HoggZillaCommented:
Ok, the SSIS package running from the SSA job is obviously not completing successfully, not matter what this says. Let's look at the SSIS package. Can you attach here or show me a screen shot.
0
thecruzAuthor Commented:
here is a SS of the package itself
importPackage.gif
0
thecruzAuthor Commented:
the package is designed to loop thrue a directory and select files by name.  It takes those files and then takes the data and imports it into SQL server.  then it copies those files and stores them in a backup directory.  Finally it deletes the files.
0
HoggZillaCommented:
In the loop for each one, put an Execute SQL Task to write the filename it finds to a table so we can look at it. Is the filepath using a UNC naming: \\server\directory? In 5 seconds it is probably not finding any files, in fact, probably can't access the directory? The user AME\RSMITH is you?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thecruzAuthor Commented:
Found the issue.  I used the UNC Path for all the file connection but i forgot to add it to the loops.  Thanks for the help.
0
HoggZillaCommented:
You are welcome!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.