Problem with WMI

I have a problem with a Server 2003. It is a DC and the WMI seems to be broken.

If I run MSINFO32 I get errors that it cannot gather information.

If I run WMIMGMT.MSC It reports Win32_Processor: Win32: Access is denied & Win_32OperatingSystem: Win32: Access denied.

I have downloaded and run WMIDIAG.vbs and have attached the report here. If someone could please give me some guidance as to how I can repair this problem so that I can install SQL 2005 Express edition I will be extremely grateful.
wmdiag-errors.zip
LVL 6
c661jmbAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

speshalystCommented:
One idea would be to check the registry on the server which gives the access
denied error for the registry value below:

HKLM\SOFTWARE\Microsoft\OLE

REG_SZ value
value name "EnableDCOM" (without the quotes)
value data of "Y" (without the quotes)

If this key and value are not present add them and then see if that helps.
 
http://forums.techarena.in/windows-server-help/8739.htm 
c661jmbAuthor Commented:
That key is already set as you described.

I have updated this server to SP2, and all other critical updates.

.Net is up to version 2 SP1

DXDIAG reports the CPU and OS.

I have tried the following scripts:
@echo on
cd /d c:\temp
if not exist %windir%\system32\wbem goto TryInstall
cd /d %windir%\system32\wbem
net stop winmgmt
winmgmt /kill
if exist Rep_bak rd Rep_bak /s /q
rename Repository Rep_bak
for %%i in (*.dll) do RegSvr32 -s %%i
for %%i in (*.exe) do call :FixSrv %%i
for %%i in (*.mof,*.mfl) do Mofcomp %%i
net start winmgmt
goto End
if /I (%1) == (wbemcntl.exe) goto SkipSrv
if /I (%1) == (wbemtest.exe) goto SkipSrv
if /I (%1) == (mofcomp.exe) goto SkipSrv
%1 /RegServer
goto End
if not exist wmicore.exe goto End
wmicore /s
net start winmgmt

when that did not work, I tried:

%SYSTEMDRIVE%
CD %windir%\system32\wbem
Mofcomp.exe cimwin32.mof
Regsvr32 /s wbemupgd.dll
Regsvr32 /s wbemsvc.dll
wmiprvse /regserver

I have attached screen shots of the permissions for the root.

screen1.JPG
screen2.JPG
screen3.JPG
screen4.JPG
c661jmbAuthor Commented:
I have also attached a later WMIDIAG report. This was run AFTER the scripts above.

wmdiag-errors2.zip
c661jmbAuthor Commented:
I am still struggling with this.

c661jmbAuthor Commented:
I fixed it - yeh, thanks to someone from another site NooNoo.

I fixed it. I threw the server in a skip and replaced it with a MAC.

Nah, I did the following:

Finally figured out a solution....

-open Administrative Tools => Local Security Policies
-find Local Policies=>Security Options=>"DCOM: Machine Launch Restriction in Security Descriptor Definition Language(SDDL)"
-in my case it was showing "Not Defined" , and I opened up the properties dialog and gave System user "Local Launch" and "Local Activation"  ALLOW.
-voila! the WMI error message is gone and the setup GUI appears.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.