Windows SBS 2008/Exchange 2007 Best Practice Error Report

I have just installed SBS and have managed to get it configured, however having run the best practice analyser, it throws some errors up which I am unable to find a resolution for:
Critical Issues:
1.  Microsoft Exchange System Attendant 'textEncodedORAddress' is missing
The 'textEncodedORAddress' value for the Microsoft Exchange System Attendant service on server MYSERVER is missing. This will cause reliability problems.

2. Transaction Log File Size
The value for the Extensible Storage Engine (ESE) transaction log file size has changed on server MYSERVER. This configuration is not supported. Current log file size is 5120 KB. Default log file size is 1024 KB.

3.  SSL is enabled
SSL is enabled for virtual directory '/W3SVC/3/ROOT/Public' on server MYSERVER.mydomain.local which has the Mailbox server role installed. This will interfere with requests to the Availability service. Please disable SSL for this virtual directory.

4.  Incorrect application pool is selected
The application pool 'SBS Web Applications application pool' is selected for virtual directory '/LM/W3SVC/3/ROOT/OAB' on server MYSERVER.MYDOMAIN.local. It's recommended that you select application pool: 'DefaultAppPool'. Please go into Internet Information Services (IIS) Manager and select the correct application pool.

Does anyone know what these error messages mean and how I should resolve them?  Some of the URL it points your towards to resolve these errors seem broken and I cant find what to do.
Nilesh8167Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raymond JansenCommented:
3. Go to IIS Mananger, Sites, default website,  select public on the left. On the right screen select SSL Settings. Clear the checkbox for Require ssl.

Restart iis and this error is gone.


Ray
0
Nilesh8167Author Commented:
Ray
Thanks for the input, I tried this but the option is greyed out.  I get an Alert saying "This sites does not have a secure binding (HTTPS) and cannot accept SSL connections."
Could this be to do with a corruption in OWA virtual folders?
0
Raymond JansenCommented:
I'm thinking out loud here: Could it be that you are using a self signed certificate? I found this website how to solve it. Please note I have NOT tested this: http://weblogs.asp.net/scottgu/archive/2007/04/06/tip-trick-enabling-ssl-on-iis7-using-self-signed-certificates.aspx

Maybe this could solve this issue.

I have almost the same errors in my config. I solved the ssl error by removing this option.

Still looking for the other errors.

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Raymond JansenCommented:
When you installed the Exchange certificate using the command line something like this: Import-ExchangeCertificate -Path c:\webmail.sslcertificaten.nl.crt | Enable-ExchangeCertificate -Services "POP, IMAP, IIS, SMTP"

Did you include the iis in services?

0
Nilesh8167Author Commented:
I did do this.  I am using SBS 2008 and all of this is automatically installed.  I am using a self certified certificate but that shouldn't be an issue on a machine joined to the domain inside the firewall.  I think is all due to the fact that the OWA directories are corrupted but to resolve the issue I need to uninstall IIS 7 and then reinstall it and the remove and readd the CA role to the server.  I am struggling to make this happen but it seems MS is convinced this is the problem.
0
Raymond JansenCommented:
Good luck 2 u my friend. I hope it works out!
0
AmitTankCommented:
Hi Nilesh,

These were the known issues with ExBPA rules update and have been corrected now. No action required for these.

Just go ahead and run ExBPA again with latest update (ExBPA.config.XML with version 12.11.18.0) and it should be disappeared.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.