The LAN clients couldn't access the server's public ip address through cisco ASA firewall

I have cisco ASA firewall and published servers on my network.clients in LAN can access the servers by their private ip address but they are not able to access the opened port of servers via server's public address.for example i have published mail server that opened the https,smtp,pop3.... ports to access it.when i surfe my mail server using browser through local ip address it comes up and works,but when i use server's public ip ,can not access it ! but if i try to access server's public ip from outside (everywhere except own LAN) it works fine. i have the same problem with all of my servers.it seems to be something with my firewall where you can take a look at its configuration below:
ciscoasa/CTX# sh run
: Saved
:
ASA Version 7.2(1) <context>
!
hostname WatanASA
domain-name Daralwatan.local
enable password xzkTqfsB.LL86smU encrypted
names
!
interface GigabitEthernet0/0
 nameif Outside
 security-level 0
 ip address 62.215.163.2 255.255.255.224
!
interface GigabitEthernet0/1
 nameif Inside
 security-level 100
 ip address 192.168.2.2 255.255.255.0
!
interface GigabitEthernet0/2
 nameif Dmz
 security-level 50
 ip address 172.17.1.1 255.255.255.0 standby 172.17.1.2
!
passwd 2KFQnbNIdI.2KYOU encrypted
dns server-group DefaultDNS
 domain-name Daralwatan.local
object-group service mail tcp
 port-object eq smtp
 port-object eq https
 port-object eq domain
 port-object eq www
object-group network internal
 network-object 192.168.10.0 255.255.255.0
 network-object 192.168.100.0 255.255.255.0
 network-object 192.168.20.0 255.255.255.0
 network-object host 192.168.20.222
 network-object 192.168.21.0 255.255.255.0
 network-object 192.168.22.0 255.255.255.0
 network-object 192.168.23.0 255.255.255.0
 network-object 192.168.24.0 255.255.255.0
 network-object 192.168.25.0 255.255.255.0
 network-object 192.168.26.0 255.255.255.0
 network-object 192.168.27.0 255.255.255.0
 network-object 192.168.28.0 255.255.255.0
 network-object 192.168.29.0 255.255.255.0
 network-object 192.168.30.0 255.255.255.0
 network-object 192.168.50.0 255.255.255.0
 network-object 172.100.10.0 255.255.255.0
 network-object 172.19.0.0 255.255.0.0
object-group icmp-type ICMP1
 icmp-object echo
 icmp-object echo-reply
 icmp-object traceroute
 icmp-object unreachable
object-group network IT
 network-object 192.168.20.0 255.255.255.0
object-group service EmailSeries tcp
 description collection of protocols for mail server
 port-object eq pop3
 port-object eq login
 port-object eq kerberos
 group-object mail
 port-object eq imap4
object-group service FtpSeries tcp
 port-object eq ftp-data
 port-object eq ftp
object-group service Baracuda tcp
 port-object eq ssh
 port-object eq smtp
 port-object eq pop2
 port-object eq pop3
 port-object eq imap4
 port-object eq https
 port-object eq www
object-group service LiveStream tcp
 port-object range 7007 7007
 port-object range 9007 9007
object-group service VPNSeries udp
 port-object range 1701 1702
 port-object range 4500 4500
 port-object eq isakmp
object-group network dmz
 network-object 172.17.1.0 255.255.255.0
access-list Inside_access_in extended permit ip any any
access-list Outside_access_in extended permit tcp any host 62.215.163.14 eq 3101
 
access-list Outside_access_in extended permit icmp any any object-group ICMP1
access-list Outside_access_in extended permit icmp any any
access-list Outside_access_in extended permit tcp any host 62.215.163.10 object-
group EmailSeries
access-list Outside_access_in extended permit tcp any any eq domain
access-list Outside_access_in extended permit udp any any eq domain
access-list Outside_access_in extended permit tcp any host 62.215.163.6 eq ftp
access-list Outside_access_in extended permit ip any host 62.215.163.11
access-list Outside_access_in extended permit tcp any host 62.215.163.17 object-
group LiveStream
access-list Outside_access_in extended permit tcp any host 62.215.163.13 eq pptp
 
access-list Outside_access_in extended permit udp any host 62.215.163.13 object-
group VPNSeries
access-list Outside_access_in extended permit ip host 168.187.168.110 host 62.21
5.163.7
access-list Outside_access_in extended permit ip host 168.187.168.110 host 62.21
5.163.8
access-list Outside_access_in extended permit ip host 62.215.231.77 host 62.215.
163.8
access-list Outside_access_in extended permit tcp any host 62.215.163.6 eq 3389
access-list Dmz_access_in extended permit icmp 172.17.1.0 255.255.255.0 any
access-list Dmz_access_in extended permit ip 172.17.1.0 255.255.255.0 any
pager lines 24
logging enable
logging standby
logging console critical
logging monitor alerts
logging buffered debugging
logging asdm informational
logging permit-hostdown
logging class ip buffered debugging console critical monitor alerts
logging class snmp history warnings
mtu Outside 1500
mtu Inside 1500
mtu Dmz 1500
icmp permit any Outside
icmp permit host 172.17.1.1 echo Inside
icmp permit host 62.215.163.2 echo Inside
icmp permit any Inside
no asdm history enable
arp timeout 14400
global (Outside) 2 62.215.163.28 netmask 255.255.255.224
global (Outside) 2 62.215.163.27 netmask 255.255.255.224
global (Outside) 2 62.215.163.29 netmask 255.255.255.224
global (Outside) 2 62.215.163.26 netmask 255.255.255.224
global (Outside) 1 62.215.163.22 netmask 255.255.255.224
global (Outside) 1 62.215.163.23 netmask 255.255.255.224
global (Outside) 1 62.215.163.24 netmask 255.255.255.224
global (Outside) 1 62.215.163.25 netmask 255.255.255.224
global (Dmz) 1 172.17.1.100-172.17.1.170 netmask 255.255.255.0
global (Dmz) 2 172.17.1.171-172.17.1.250 netmask 255.255.255.0
nat (Inside) 1 172.100.10.0 255.255.255.0
nat (Inside) 2 192.168.10.0 255.255.255.0
nat (Inside) 1 192.168.20.0 255.255.255.0
nat (Inside) 2 192.168.21.0 255.255.255.0
nat (Inside) 1 192.168.22.0 255.255.255.0
nat (Inside) 2 192.168.23.0 255.255.255.0
nat (Inside) 1 192.168.24.0 255.255.255.0
nat (Inside) 2 192.168.25.0 255.255.255.0
nat (Inside) 1 192.168.26.0 255.255.255.0
nat (Inside) 2 192.168.27.0 255.255.255.0
nat (Inside) 1 192.168.28.0 255.255.255.0
nat (Inside) 2 192.168.29.0 255.255.255.0
nat (Inside) 1 192.168.30.0 255.255.255.0
nat (Inside) 2 192.168.50.0 255.255.255.0
nat (Inside) 1 192.168.100.0 255.255.255.0
nat (Inside) 2 172.19.0.0 255.255.0.0
static (Inside,Outside) 62.215.163.3 192.168.10.50 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.4 192.168.10.54 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.5 192.168.10.56 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.6 192.168.10.29 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.7 192.168.10.38 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.8 192.168.10.39 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.9 192.168.10.48 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.13 192.168.10.66 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.10 192.168.10.35 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.11 192.168.10.32 netmask 255.255.255.255
static (Inside,Outside) 62.215.163.14 192.168.10.36 netmask 255.255.255.255
static (Dmz,Outside) 62.215.163.17 172.17.1.20 netmask 255.255.255.255
access-group Outside_access_in in interface Outside
access-group Dmz_access_in in interface Dmz
route Outside 0.0.0.0 0.0.0.0 62.215.163.1 1
route Inside 172.100.10.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.20.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.21.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.22.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.23.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.24.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.25.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.26.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.27.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.28.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.29.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.30.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.50.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.100.0 255.255.255.0 192.168.2.1 1
route Inside 192.168.10.0 255.255.255.0 192.168.2.1 1
route Inside 172.19.0.0 255.255.0.0 192.168.2.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 Inside
http 192.168.10.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
telnet 192.168.20.0 255.255.255.0 Inside
telnet 192.168.10.0 255.255.255.0 Inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 Inside
ssh timeout 5
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
Cryptochecksum:11572a69e22d0bde62893aeb9c83083a
: end

Open in new window

wrefaiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

H_HarryCommented:
It wont be possible to do it in the manner you are trying. All your NAT rules appear to have the hosts on the Inside network. The PIX is unable to send traffic back out if an interface it receives it on.
You data is going to the PIX (your default gateway I presume) the PIX see's the external IP and realises that it needs to NAT the traffic to an internal IP and send it back to the host defined in the NAT statement - but as these hosts are also on the inside interface it can not send the traffic back through it (as this is where it came from in the first place), so it simply drops the traffic.
There is no possible configuration to make it do this - it is the way it is designed to function.
You could put the hosts on a different interface but the PIX still won't really address the traffic to the external IP, it will see the NAT rule and just send it out of the interface addressed to the internal IP(s).
 
0
H_HarryCommented:
It you absolutley have to address the traffic to the external IP you will need to put a host on the outside interface and it will work fine (as you appear to have done). This is really the only plausable way to do it i'm afraid.
 
 
0
wrefaiAuthor Commented:
Dear H_Harry , Since i had cisco ASA 4410 , this scanerio was working perfect on that before i replaced it with new asa 4420.Same configuration applied there but clients were accessing servers in the same manner with no issue.if there is no solution for this trouble then how my users can see mail server by typing real DNS name in browser??
0
lrmooreCommented:
>how my users can see mail server by typing real DNS name in browser??
By simply having an internal dns server that resolves the name to the private ip address.

You can also try this trick:
Create both inside,outside and outside, inside statics:

static (Inside,Outside) 62.215.163.3 192.168.10.50 netmask 255.255.255.255
static (Inside,Inside) 62.215.163.3 192.168.10.50 netmask 255.255.255.255

same-security-traffic permit intra-interface

Reference:
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807968d1.shtml#solution2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wrefaiAuthor Commented:
Dear lrmoore, it did work perfect,thanks for your solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.