Need basic config for my 3560g

I need help on setting up new switch for my office. Here is my scenerio:

I have a Cisco 3560g 24 port switch w/4 sfp's that will connect directly to my ISP's Cisco 1841.
Info from ISP:
IP address : 12.70.129.120
subnet: 255.255.255.248
Default gateway: 12.70.129.121

My inside network is 192.168.1.0
w/16 workstations and 2 unmanaged switch's(they will connect to the sfp ports)

Can anyone assist me with a config template to allow workstations to be networked and be able to access the internet?

Thanks in advance.
 
szavAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RTh0037Commented:
!
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname <Name>
!
enable secret 5 TBD
!
username TBD
no aaa new-model
vtp mode transparent
ip subnet-zero
no ip domain-lookup
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
 name LAN
!
interface GigabitEthernet0/1
 description To firewall LAN
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 no cdp enable
!
interface GigabitEthernet0/2
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/3
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/5
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/6
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/7
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/8
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/9
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/10
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/11
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/12
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/13
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/14
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/15
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/16
 description LAN Host
 switchport access vlan 2
 switchport mode access
 switchport block multicast
 switchport block unicast
 spanning-tree portfast
!
interface GigabitEthernet0/17
 description Not Used
 shutdown
!
interface GigabitEthernet0/18
 description Not Used
 shutdown
!
interface GigabitEthernet0/19
  description Not Used
  shutdown
!
interface GigabitEthernet0/20
  description Not Used
  shutdown
!
interface GigabitEthernet0/21
  description Not Used
  shutdown
!
interface GigabitEthernet0/22
 description Not Used
 shutdown
!
interface GigabitEthernet0/23
 description Not Used
 shutdown
!
interface GigabitEthernet0/24
 description Not Used
 shutdown
!
interface GigabitEthernet0/25
 description Uplink to unmanaged
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/26
 description Uplink to unmanaged
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/27
 description Not Used
 shutdown
!
interface GigabitEthernet0/28
 description Not Used
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 192.168.1.0 255.255.255.0
 no ip route-cache
ip default-gateway (Cisco 1841 interface)
ip classless
ip http server
!
!
control-plane
!
banner motd ^C
WARNING!!!: Unauthorized access and use of this network will be vigorously prosecuted.
WARNING!!!: All activity is monitored and privacy should not be expected while using this system.^C
!
line con 0
line vty 0 4
 login local
line vty 5 15
 no login
!
end
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
szavAuthor Commented:
Thanks RTh0037 for the quick reply. Quick question: Would this need to be natted? If so, what configuration would need to be placed? Would I need to configure anything to allow vpn to our server?

Thanks again RTh0037.

0
szavAuthor Commented:
I tried the configs in my environment and can't connect to the internet. I can ping everything inside my network, just not outside. I enabled ip routing and an static ip route. When I issue an sh ip route command, the entry I can see is my inside network w/no static routes. Can anyone tell me what I am doing wrong?

Thank you
0
RTh0037Commented:
What does the config look like on the 1841?  I assumed this was being used as the security layer for your LAN.  With this assumption, you would need a interface on that 1841 in the same subnet as the 192.168 subnet.

0
szavAuthor Commented:
It's fixed. Your configs worked brother. I appreciate all the help RTh0037.

Regards.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.