Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 243
  • Last Modified:

Public Folders SSL issue

This question may infact be two questions, though I'm not sure.

This is the situation.

I've added a second Exchange 2003 SP2 server to the organisation and configured public folder replication. I also moved some mailboxes from the old server to the new server - all ok. Users are able to log in and get emails etc.

The public folders however, they are not working properly. Before I added the second server, everything worked correctly. Now however, when I open ESM from the old server and open public folders, select a folder and click the "contents" tab, i get:

information you exchange with this site cannot be view or changed by others. However, there is a problem with the site's security certificate.

(Green Tick) The security certificate is from a trusted certifying authority.

(Green Tick) The security certificate date is valid.

(Yellow !) The name on the security certificate is invalid or does not match the name of the site.

Do you want to proceed?

--

I hit "Yes" and the message returns. After clicking "yes" 5 times, it proceeds with the loading of contents. The SSL cert has been issued to external.company.com as opposed to server.local, so i understand the error, though I'm unsure as to why it has started just now. In ESM, the replication status for the old server says "In Sync" and for the new server "Local Modified".

Now on the new server itself, using ESM, i can't see any of the public folders at all. Everything else is ok, users/mailboxes etc. Users can no longer see any of the public folders from outlook (regardless of whether they are located on the old or new server). They can however create new public folders (they appear in ESM on the new server).

Worst part (or possibly best) is that there are no error messages in the logs whatsoever, not on either server. Not a single error.

Seems to me that the new server is not able to access the PF store on the old server. I setup replication 12 hours ago - so far nothing. the pub1.edb on the new server is 2mb. 50GB on the old server.

I don't use the SSL cert for activesync etc, so i can remove it if neccessary but i want to be sure that it is the problem. it has always been there with no issue.

Look forward to your response - thanks.
0
Charlie8
Asked:
Charlie8
  • 2
1 Solution
 
Charlie8Author Commented:
Update:

Just checked the queue in ESM on the old server, 52,000 messages queued to goto the new server. i imagine these must be all the public folder messages.

i went into IIS manager and removed the SSL cert from the old server - rebooted the server.

1. the error in ESM on the old server no longer appears.
2. the message queue on the old server has come down to 4000 and is going up slowly.
3. public folders are still not viewable using outlook (for users on either server)
4. ESM on the new server displays none of the public folders (replication not working)
5. still no log errors on either server.

Thanks.
0
 
Charlie8Author Commented:
Worked it out.....you have to remove smart hosts on both servers, otherwise both servers try to push PF replication data (SMTP) out via the SH.

Sorted.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now