?
Solved

New Drive Won't Partition Correctly

Posted on 2008-11-15
16
Medium Priority
?
341 Views
Last Modified: 2013-12-01
Greetings Experts,

I bought an OEM 1TB drive by Samsung to replace my 300 gig drive and today I attempted to install it as my main hard disk.  As you can imagine, it didn't work hence my question here.  

First, my system info:

XP Pro, SP3 all updates.
Intel Core 2 dual processor, 2ghz, 2 gig DDR2 RAM (800mhz)
300 gig hard drive (100 gigs free space) SATA
Gigabyte S-series motherboard, model GA-P35-DS3L

The problems:

I use Acronis for my back up software so I decided to clone my old HD to the new one.  I connected Samsung drive, booted up and the system seem to recognize it.  I started up Acronis, selected the cloning process, pointed it to the Samsung disk and let it go.  It rebooted and started the cloning process.  Note that for the cloning process, my old HD occupied disk 0 connection (which is where it was originally) and the Samsung was on the disk 1 connection.  Before I rebooted after the cloning had finished, I switched the HDs connections so that the Samsung was on disk 0 and the old drive was now disk 1

Acronis told me the cloning was successful but upon reboot, the machine couldn't get to the desktop and threw an error saying that it couldn't read the HD disk.  I switched the disks back (old disk on drive 0, samsung on drive 1) and it worked but it booted using my old HD.

I check out the new disk in My Computer and it showed only 7.85 gigs and when I doubled clicked on it, a window would open asking if wanted to format it.  I went into disk management and deleted the partition.  Using Partition Magic 8 I then tried to recreate the partition but it will only allow me to create a partition of 8 gigs!

What did I do wrong?  Is there a way that I can reformat this drive back to its 1 TB capacity?
0
Comment
Question by:max7
  • 4
  • 4
  • 3
  • +3
16 Comments
 
LVL 50

Expert Comment

by:dbrunton
ID: 22969879
Sounds like either the BIOS doesn't support the hard drive or the hard drive has been jumpered for a legacy mode.

Check the BIOS to see what capacity it sees.

Also check your motherboard manual to see what the maximum capacity drive is supported.
0
 
LVL 1

Author Comment

by:max7
ID: 22969923
Thanks for the response -
I noticed on this hard disk that, while it has jumpers, none are selected with the customary little white plastic cap.  The cap itself does not exist so the jumpers are bare.  I assumed that since this was SATA jumpers wouldn't be an issue . . . how wrong am I on that?
I went to the manufacturers website and I didn't find a specific reference to max drive capacity.  I did find it's description of storage interface which is 4 Serial ATA 3Gb/s plus 1*PATA (when I'm feeling nostalgic?).  My thought is, if the board has SATA connections that accept data transfer speeds of up to 3gigs/s, I would assume the board could handle a terabyte drive.  What do you think of my logic?
I will check the BIOS as soon as windows is done attempting to format this drive (going rather slow) and I will let you know what I find out.
 
 
 
0
 
LVL 12

Expert Comment

by:David Wall
ID: 22969925
\there is a samsung troubleshooting schema here http://www.samsung.com/global/business/hdd/support/troubleshooting/Support_Troubleshooting.html

Also samsung mantions that some bios's wont see the new drive this tool may help http://www.samsung.com/global/business/hdd/support/utilities/Support_DiskManager.html
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
LVL 50

Assisted Solution

by:dbrunton
dbrunton earned 500 total points
ID: 22969939
>> My thought is, if the board has SATA connections that accept data transfer speeds of up to 3gigs/s, I would assume the board could handle a terabyte drive.  What do you think of my logic?

The idea is nice but let's see if the BIOS agrees with your logic. :)
0
 
LVL 1

Author Comment

by:max7
ID: 22970013
I checked the BIOS and it sees my 300 gig drive just fine (it actually shows it as 320 which is correct).  For the new HD, it sees the following:
Capcity: 33 mb
Cylinders: 64
Head: 16
Precomp: 0
Landing Zone: 63
Sector: 63
As an added bonus, Windows decided after a couple of hours acting like it was successfully formatting the disk, tells me at the very end that the disk cannot be formatted.  Same goes for Parition Magic 8.
So barring any amazing plans to resurrect this drive from the data dead, it seems as if tomorrow I'm going back to the retailer and getting a new drive but I still want to know: did I do something wrong?  What is the proper procedure to prepare a drive to replace your old drive?  Should I have formatted it before I tried cloning my original drive with Acronis?
I would appreciate a brief but concise point by point flow of how to do this right so I don't mess up again (assuming I did this time).
 
 
0
 
LVL 50

Expert Comment

by:dbrunton
ID: 22970039
The BIOS is not seeing the drive correctly.  There may be options in your BIOS to flip the way it sees the drive, such as LBA, Legacy etc.  Try those if they exist.

See if there is a manual for your SATA drive to change the jumper settings.  Samsung used to include those with their drives.

Check your motherboard manual.  You may have to download one from the Gigabyte people and see what is the max capacity it can support.

You've done nothing wrong.  There's either something not set properly or the motherboard doesn't support 1 Tb drives or there is an incompatibility with the motherboard and the drive.
0
 
LVL 93

Expert Comment

by:nobus
ID: 22970297
i would redo the clonning, and verify what partition size it proposes; you can delete all partitions first to be sure the disk is clean, using bootit NG : www.terabyteunlimited.com/ 
then create a partition of 1 TB      
Acronis should propose a new parttion of 1 TB; and after the cloning, disconnect the old disk, and start frm the cloned one alone !
0
 
LVL 32

Accepted Solution

by:
willcomp earned 700 total points
ID: 22970886
BIOS support for large hard disks is not a problem on your motherboard.

I recommend using Samsung diagnostics to test the hard disk and verify parameters. Samsung and other manufacturers' diagnostics are on the UBCD. Also do a zero fill (low level format) of the disk. Disconnect your old hard disk while testing.
http://www.ultimatebootcd.com/
0
 
LVL 1

Author Comment

by:max7
ID: 22971752
Latest Update,
I created the Ultimate Boot cd, a very handy thing to have.  Oddly enough none of the Samsung disk utilities would work with my disk!  There were three to choose from: one would recognize the disk but said it wasn't built to work with that model.  The other wouldn't even recognize the disk  insead seeking legacy drivers and proper jumper settings.  Out of desperation, I tried disk utilities by other companies thinking that some might work and sure enough, the Hitachi one did work.  It reset my HD to it's true capacity (1000 gigs).  I went into BIOS and all looked good.
I am now using Disk Management in XP to format a drive partition.  Assuming that succeeds (I take nothing for granted in this whole ordeal), I am back at square one and I still don't know what went wrong.  It seems to me the trouble really started after using Acronis to clone the disk.  
I also have doubts about using Partition Magic 8.  After restoring the capacity of my HD, I launched PM8 to create a new partition.  I selected to make it a primary drive so I could evnetually boot an OS from but PM8 warned me that since it crossed the "cylinder barrier" it might not boot.  
My questions are:
  • Is PM8 too old to use and might cause me more trouble (it's last release was around 2002)?
  • With Acronis, should I try to store my last disk image instead of cloning or should that even matter?
  • Any other thoughts about how to avoid further disaster in mounting this new HD?
0
 
LVL 12

Expert Comment

by:David Wall
ID: 22971941
try the disk in another machine to see if it works there just to make sure the disk is O.K.

and it isnt the motherboard.
0
 
LVL 93

Assisted Solution

by:nobus
nobus earned 400 total points
ID: 22973809
>>  Oddly enough none of the Samsung disk utilities would work with my disk!    <<   probably they do not support SATA !
did you use this program (ES tool) :  http://www.samsung.com/global/business/hdd/support/utilities/Support_DiskManager.html
0
 
LVL 47

Assisted Solution

by:noxcho
noxcho earned 400 total points
ID: 22975670
Try other partitioning tools first: http://www.paragon-software.com/home/pm-personal/ 
It is Paragon made and I have just tested for 1TB drive support. Was done smoothly.
Then check if your problem is HPA related: http://www.goodells.net/dellrestore/hpa-issues.htm
Actually you need to wipe the drive (fill it with zeroes) so to bring it back to original state. Then use other software than Acronis to create copy or clone via backup\restore operation.
Drive Backup 9.0: www.drive-backup.com can do this also easily.
0
 
LVL 93

Expert Comment

by:nobus
ID: 22976674
for your diag to run, check in the bios the sata settings, and use compatible mode !
0
 
LVL 1

Author Closing Comment

by:max7
ID: 31517211
Well, I resolved it.  It seems that perhaps I needed to prepare (read format) the disk before I ran Acronis to clone my old HD to it -- I can't be sure.  What i know is, after resetting the new HD with the Hitachi utility I was then able to format it and then clone my old disk to it.  Between MS Disk Management and PM8 I was able to resassign the drive level and securely erase it and life is good again.  Thanks to you all for your support and guidance!  I wish I could give out more points.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 22980196
Glad to help and pleased you got problem resolved. I'd guess that when you originally cloned old disk that you cloned a partition rather than the entire disk. Once partitions get improperly set, best way to clear is a zero fill.
0
 
LVL 93

Expert Comment

by:nobus
ID: 22982587
tx for the feedback  !
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In real business world data are crucial and sometimes data are shared among different information systems. Hence, an agreeable file transfer protocol need to be established.
"Any files you do not have backed up in at least two [other] places are files you do not care about."
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question