L 99 99 99 99 99 99... displaying in bootup

I got Debian 4.0 server, when I bootup, it shows L 99 99 99 99 99 ..
Is there a way to fix this without  formatting the drive? I need all the configuration files and services.
Can anyone please help me?
toffee_natividadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ibu1Senior System AdministratorCommented:
Hi,
The problem seems to be in LILO.Refer here for more information
http://wiki.linuxquestions.org/wiki/LILO_Error_Codes

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ibu1Senior System AdministratorCommented:
Here is the tutorial for LILO,if u dont know more detail about lilo configuration.
http://www.djack.com.pl/Suse9hlp/ch08s05.html
toffee_natividadAuthor Commented:
Do you think this is fixable? My services and files will be restored?
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

ravenplCommented:
Depends. If it's only lilo which got corrupted, then surely yes - simply got the recovery disk (or any livecd distro), boot to Your partition (or chroot after boot) and reinstall lilo. The link above is good start.
toffee_natividadAuthor Commented:
tried those links.  The problem is that rescue disk doesn't set the
root to the image on the hard drive to use as root.  

ravenplCommented:
You could find it by yourself? Then mount it...
toffee_natividadAuthor Commented:
I'm sorry what do you mean I can fing it myself? Thanks
ravenplCommented:
Well if You know the partiion where the original OS was installed, then after booting rescueCD/liveCD You could

mkdir /tmp/1
mount /dev/sdXY /tmp/1 # read notes
mount -o bind /proc /tmp/1/proc
chroot /tmp/1 /sbin/lilo

#notes, sdXY mean Y(number) partition on Xth scsi/sata drive.
#to list partitions on given hdd
fdisk -l /dev/sda #or sdb etc.
fdisk -l /dev/hda #or hdb etc.
toffee_natividadAuthor Commented:
thanks. I will give it a try,
toffee_natividadAuthor Commented:
mount -o bind /proc /tmp/1/proc ---> I am sitting next to my supervisor My supervisor is asking, Why is this step necessary?

Thanks a lot
ravenplCommented:
mount -o bind /proc /tmp/1/proc
mount -o bind /dev /tmp/1/dev

when You chroot to /tmp/1 to install lilo, it will require at leasy valid /dev, /proc is good as well.
So as You see I even forgot about the /dev binding.
toffee_natividadAuthor Commented:
I will try this
thanks
toffee_natividadAuthor Commented:
tried it raven,,

"fatal: read /vmlinuz: No such device or address
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.