Protected Operating System folder change

One of our main Data folders somehow has been changed so it will only show up if "Hide protected operating system files" is unchecked.  Is there any way to change it back?
LVL 6
Michael SAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeTutorretiredCommented:
Have you tried going to a CMD prompt, changing directory to the parent directory of your system folder, then using the ATTRIB command to turn off the S (System) attribute?  You will need to be an Administrator, you might need to use Run as Administrator option for the CMD.EXE.  Don't know how much of a "guru" you are on DOS commands, but you change directory with the CD command.  You can get the syntax of the CD and the ATTRIB commands by typing each one with a /? option, e.g.,   CD /?
0
theras2000Commented:
That means they've got the 'System' attribute enabled - it's what makes that checkbox show or hide them.  The DOS attrib command will help you, but let me find exactly how to use that on a whole folder.
0
theras2000Commented:
Ahh here we go.  If your Data folder is in C:, liek C:\Data, then open a DOS command prompt to C:\.
Now just type 'attrib +s data'.  Done.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

LeeTutorretiredCommented:
It is not ATTRIB +S DATA, that turns ON the System Attribute. Use a minus sign instead of a plus sign...
0
theras2000Commented:
Oh my apologies.  It seems that the folder must be marked as hidden + system, before your checkbox will hide it.  So type 'attrib -s data' to undo that.  Then type 'attrib +s +h data'.
You have to add both attributes at the same time, so the first bit must be undone beforehand.
I've tested it and it's working for me now by using your checkbox.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael SAuthor Commented:
I didn't even think about the command prompt, I was thinking of some Windows setting.  But I did that and it worked, so that works for me...thanks.
0
LeeTutorretiredCommented:
I wonder why you didn't split the points, since I was the first expert to suggest it, and I even corrected one of the comments by theras2000...
0
Michael SAuthor Commented:
Because I was in a hurry.
0
theras2000Commented:
Gee what a schmuck I was; sorry Jay.  I was so focussed on trying to turn it on that I forgot you were looking to turn it off.  Anyway it sounds like you realised that you needed to use minuses instead of pluses in my syntax.
0
umaiir2000Commented:
just a little bit change in the theras2000: answer
type 'attrib -s -h data'. to unhide the folder and to unmark it as a system file.


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.