Data Execution Prevention error followed by SVChost.exe error

I have a Sony VGN- FS640/W laptop That seems to be running OK but I get a Data Execution Prevention error when it boots followed by a svchost.exe application error 0x00ce96bc.  Then it seems to be fairly ok after that however the SVCHOST.exe Application error comes back when I try various things such as double clicking on My Computer.  I first get the flashlight for 20 seconds, then the svchost.exe error and then finally the contents of the drive show up.  I have scanned for viruses and Spyware and it is clean.  I still get the errors if I disable all startup items and non-microsoft service as well as in safe mode.
LVL 1
waytronAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andrew_aj1Commented:
Try turning off DEP. These instructions will help:
http://www.tech-recipes.com/rx/566/xp-sp2-how-to-turn-off-the-data-execution-prevention-feature-dep/
Hopefully after that  these errors will go away.
I hope this helps. Good luck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
waytronAuthor Commented:
Tried that earlier, Still getting the Svchost.exe error
0
waytronAuthor Commented:
Ok, I finally found it and I should have known.  All the problems went away when I uninstalled an HP AIO printer.  I am really starting to hate HP AIO printers they cause more problems than Norton Antivirus.  
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

jeebukarthikeyanCommented:
Open My Computer, right click on properties. Select the Advanced tab. Under Preformance click on settings and select the Data Exe Prevention tab.
0
prasminCommented:
It seems that any malacious script/code is trying to overwrite the memory and the Microsoft DEP technology is preventing the malacious script/code to overwrite it in memory. Try update the OS and the Antivirus and the problem would be solved.
0
waytronAuthor Commented:
Prior to solving the problem by uninistalling HP AIO printer (see my comment above), I had uninstalled Antivirus completely and installed all Windows updates but it did not help the problem.
0
waytronAuthor Commented:
thanks for the assistance
0
ChenyCommented:
I have the same problem...

I got svchost.exe - Application Error
The instruction at "0x00ce96bc" referenced memory at "0x0000000". The memory could not be written.

Who can help me???
0
ChenyCommented:
none of solution is working to me
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.