Activesync not syncing - Error: Activesync encountered a problem on the server 0x85010014

I have been working on this problem for the past 24 hours (almost solid), and found no solutions online that worked, or had the exact same symptoms.  I have finally solved this, and am posting it so that others don't have to go through the same garbage I did.

----------------------------------------------------------------------------------------------
STARTING CONFIGURATION:

  -  2 servers
  -  Server 1 (Back-End) / SVR01:
     - WIndows Server 2003 R2 Ent x86 (SP2)
     - Domain Controller
     - DNS Server
     - Exchange 2003 SP2: Back-End Server, RPC Back-End
  -  Server 2 (Front-End) / SVR02:
     - WIndows Server 2003 R2 Ent x86 (SP2)
     - Exchange 2003 SP2: Front-End Server, RPC Front-end, SSL Certificate

All Exchange services were working fine through the front-end server to the back-end: OWA (SSL), OMA (SSL), RPC over HTTPS, Activesync (SSL), IMAP (SSL)

----------------------------------------------------------------------------------------------
STEPS LEADING TO THE PROBLEM

  1)  Needed to reload Server 2 (SVR02), in order to reconfigure the disk partitions..
  2)  Uninstalled Microsoft Exchange from Server 2 (SVR02) using the setup files.  The uninstall was successful.
  3)  Removed Server 2 (SVR02) from the domain, and verified that the server was no longer in Active Directory or Exchange System Manager.  The uninstallation of this server from the environment was clean.
  4)  Reloaded Server 2 (SVR02) with Windows 2003 R2 Ent (SP2), and added the new, fully-patched server to the domain with the same name as before:SVR02
  5)  Installed Exchange 2003 SP2 into Server 2 (SVR02), with no issues.
  6)  Installed the SSL Certificate into IIS 6 using the IIS Manager.
  7)  Made Server 2 (SVR02) a front-end server, and front-end RPC Proxy

----------------------------------------------------------------------------------------------
>> THE PROBLEM <<

  -  RPC over HTTPS: Working
  -  OWA (SSL): Working
  -  OMA (SSL): Working
  -  IMAP (SSL): Working
  -  ActiveSync: >>NOT WORKING<<

I enabled verbose event logging for ActiveSync on my device so that I could troubleshoot the problem more efficiently:
  1)  Go to ActiveSync on the device, and select: Menu -> Configure Server
  2)  Continue through the ActiveSync pages until you get to the point where you select what you want to sync (Contacts, Calendar, E-Mail, Tasks)
  3)  Go to Menu -> Advanced
  4)  Change "Event Logging" from "None" to "Verbose"

ActiveSync issue:
Whenever ActiveSync is configured on any Windows Mobile device, using any account in the organization, the following problem sequence comes up:
  1)  ActiveSync attepts to connect, and briefly displays: "Synchronizing Folders", then stops
  2)  Activesync displays the error: "ActiveSync encountered a problem on the server", with the error code 0x85010014
  3)  In the logs on the device (located in \Windows\ActiveSync\Microsoft Exchange0.txt), the following information comes up at the last aprt of the log:
        =-=- [15/11/2008 9:42:24.0] -=-=
        =-=-=-= Server Response =-=-=-
        HTTP/1.1 500 Internal Server Error
        Date: Sat, 15 Nov 2008 16:42:59 GMT
        Server: Microsoft-IIS/6.0
        X-Powered-By: ASP.NET
        Pragma: no-cache
        Content-Type: text/html
        Content-Length: 56
        MS-Server-ActiveSync: 6.5.7638.1
LVL 3
hp_be_messagingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hp_be_messagingAuthor Commented:
----------------------------------------------------------------------------------------------
>> TROUBLESHOOTING AND SOLUTION <<

I ended up doing a lot of troubleshooting, and a lot of research into various articles.

  1)  Verified that there were no SSL requirements in IIS on the back-end server (SVR01): PROBLEM STILL EXISTS
  1)  Reloaded the front-end, Server 2 (SVR02), from scratch again: PROBLEM STILL EXISTS
  2)  Re-issued the SSL certificate, and verified SSL functionality: PROBLEM STILL EXISTS
  3)  Changed the front-end server to not require SSL for any functions: PROBLEM STILL EXISTS
  4)  Removed exchange attributes and rebuilt the mailbox for my own user account: PROBLEM STILL EXISTS (still exists for all accounts)

After much more troubleshooting and investigation, I decided that the problem must be with the back-end server (SVR01).  I looked around for instructions on reloading / rebuilding the Exchange IIS directories and virtual directories, and finally came across this Microsoft KB Article, which outlined it perfectly: http://support.microsoft.com/kb/883380 - "How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003"

I used method 2 located in this KB article to rebuild the virtual directories on the back-end Server 01 (SVR01), and it has fixed my problem!  All services are fully functional now.



>> QUOTED FROM THE MICROSFT KB ARTICLE 883380
>> >> Method 2: Use Adsutil.vbs
>> >> 1. Back up your IIS Metabase. To do this, follow these steps: a.  Start IIS Manager.
>> >> b.  Right-click Default Web Site, point to All Tasks, and then click Save Configuration to a File.
>> >>  
>> >> 2. Delete the virtual directories for Outlook Web Access. To do this, right-click Exadmin in the left pane of IIS Manager, and then click Delete. Click Yes when you are prompted with the question of whether you want to delete this item.
>> >>
>> >> Repeat this step for the following virtual directories: " Exchange
>> >> " ExchWeb
>> >> " Microsoft-Server-ActiveSync
>> >> " OMA
>> >> " Public
>> >>  
>> >> 3. Quit IIS Manager.  
>> >> 4. Click Start, click Run, type cmd, and then press ENTER.
>> >> 5. Change to the following folder. In this example, Drive is the hard disk drive where Windows is installed:
>> >> Drive:\inetpub\adminscripts
>> >> 6. Type adsutil, and then press ENTER.
>> >>
>> >> Important By default, CScript is not the default scripting host for Windows Server 2003. To run the adsutil command, CScript must be configured as the default scripting host. To do this, click Yes if you are prompted to register CScript as you default host for VBscript, and then click OK.
>> >>
>> >> Note If you receive a list of adsutil command options, CScript is already configured as the default scripting host for VBscript.
>> >> 7. Type adsutil delete ds2mb, and then press ENTER.
>> >>
>> >> Note To set the default scripting host to WScript, type WScript //H:WScript at the command prompt, press ENTER, and then click OK.
>> >> 8. Click Start, point to All Programs, point to Administrative Tools, and then click Services.
>> >> 9. To restart the Microsoft Exchange System Attendant service, follow these steps: a.  Click Start, click Run, type services.msc, and then click OK.
>> >> b.  Right-click Microsoft Exchange System Attendant, and then click Restart.
>> >> c.  When you are prompted to restart the dependant Exchange Server services, click Yes.
>> >>
>> >> Note When you restart the Microsoft Exchange System Attendant service, the Microsoft Exchange Information Store service is also restarted. In this scenario, your Exchange Server users lose connectivity to their Exchange Server mailboxes.
>> >>
>> >> The virtual directories are re-created. To verify that the virtual directories are re-created, start IIS Manager, and then view the Default Web site folder.
>> >>
>> >> Important If the virtual directories are not re-created after 15 minutes, restart the computer.
>> >>  
>> >> 10. Reset the access permissions to Anonymous. To do this, follow these steps:a.  Start IIS Manager, right-click ExchWeb, click Properties, and then click the Directory Security tab.  
>> >> b.  Under Authentication and access control click Edit, and then verify that the Enable anonymous access check box is turned on.  
>> >> c.  Click to select the Integrated Windows authentication check box, click OK, and then click Apply.
>> >> d.  If an Inheritance Overrides dialog box appears, click Select All, and then click OK.
>> >> e.  Under Authentication and access control, click Edit, and then click to clear the Integrated Windows authentication check box.
>> >> f.  Click OK two times, and then quit IIS Manager.
>> >>  
>> >> Use a Web browser to verify that you can connect to your Outlook Web Access server. If you are also running other mobility services, verify that you can connect to these services by using an appropriate client.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.