Linux High Availability (HA)

I am trying to install HA on two suse10 servers.

The problem i face is that i cant assign the virtual ip address from HA. HA starts but no subinterface is created!

This interface is automatically created OR  do i have to create it manually?

The files and the logs follow:

suse1:/etc/ha.d # cat ha.cf
logfile /var/log/ha-log
logfacility local0
auto_failback yes
crm no
bcast eth0
node suse2
node suse1
respawn root /sbin/evmsd
apiauth evms uid=hacluster,root
debug 1





suse1:/etc/ha.d # cat haresources
suse1 Ipaddress::10.19.146.175::eth0 httpd






suse1:/etc/ha.d # /etc/init.d/heartbeat restart
Stopping High-Availability services                                   done
logd[5523]: 2008/11/16_20:45:36 debug: Stopping ha_logd with pid 5362
logd[5523]: 2008/11/16_20:45:36 info: Waiting for pid=5362 to exit
logd[5523]: 2008/11/16_20:45:37 info: Pid 5362 exited
Starting High-Availability services2008/11/16_20:45:52 ERROR: Cannot locate resource script Ipaddress
/usr/lib/heartbeat/ResourceManager: line 208: 10.19.146.175: command not found
heartbeat[5564]: 2008/11/16_20:45:53 debug: uid=hacluster, gid=<null>
heartbeat[5564]: 2008/11/16_20:45:53 debug: uid=hacluster, gid=<null>
heartbeat[5564]: 2008/11/16_20:45:53 debug: uid=<null>, gid=haclient
heartbeat[5564]: 2008/11/16_20:45:53 debug: uid=root, gid=<null>
heartbeat[5564]: 2008/11/16_20:45:53 debug: uid=<null>, gid=haclient
heartbeat[5564]: 2008/11/16_20:45:53 debug: Beginning authentication parsing
heartbeat[5564]: 2008/11/16_20:45:53 debug: 16 max authentication methods
heartbeat[5564]: 2008/11/16_20:45:53 debug: Keyfile opened
heartbeat[5564]: 2008/11/16_20:45:53 debug: Keyfile perms OK
heartbeat[5564]: 2008/11/16_20:45:53 debug: 16 max authentication methods
heartbeat[5564]: 2008/11/16_20:45:53 debug: Found authentication method [md5]
heartbeat[5564]: 2008/11/16_20:45:53 info: AUTH: i=1: key = 0x80efad0, auth=0xb7ee9b94, authname=md5
heartbeat[5564]: 2008/11/16_20:45:53 debug: Outbound signing method is 1
heartbeat[5564]: 2008/11/16_20:45:53 debug: Authentication parsing complete [1]
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(cluster,linux-ha)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(hopfudge,1)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(keepalive,1000ms)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(deadtime,30000ms)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(baud,19200)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(hbgenmethod,file)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(realtime,true)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(msgfmt,classic)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(conn_logd_time,60)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(log_badpack,true)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(coredumps,true)
heartbeat[5564]: 2008/11/16_20:45:53 WARN: Core dumps could be lost if multiple dumps occur
heartbeat[5564]: 2008/11/16_20:45:53 WARN: Consider setting /proc/sys/kernel/core_uses_pid (or equivalent) to 1 for maximum supportability
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(autojoin,none)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(uuidfrom,file)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(compression,zlib)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(compression_threshold,2)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(traditional_compression,no)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(max_rexmit_delay,250)
heartbeat[5564]: 2008/11/16_20:45:53 debug: Setting max_rexmit_delay to 250 ms
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(record_config_changes,on)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(record_pengine_inputs,on)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(enable_config_writes,on)
heartbeat[5564]: 2008/11/16_20:45:53 debug: add_option(memreserve,6500)
heartbeat[5564]: 2008/11/16_20:45:53 WARN: Logging daemon is disabled --enabling logging daemon is recommended
heartbeat[5564]: 2008/11/16_20:45:53 info: **************************
heartbeat[5564]: 2008/11/16_20:45:53 info: Configuration validated. Starting heartbeat 2.0.5
heartbeat[5564]: 2008/11/16_20:45:53 debug: HA configuration OK.  Heartbeat starting.
                                                                      done


Thanks
LVL 10
amprantiAsked:
Who is Participating?
 
amprantiConnect With a Mentor Author Commented:
File /etc/ha.d/haresources is used for v1.
v2 used cib.xml
0
 
amprantiAuthor Commented:
After some more searching i fixed the problem with haresources:

suse2:/etc/ha.d # cat haresources
suse1 10.19.146.175 httpd


For some reason a subinterface ISNT created! Any idea why?

Thanks
0
 
amprantiAuthor Commented:
Starting High-Availability services2008/11/17_08:21:46 INFO: IPaddr Resource is stopped
heartbeat[3926]: 2008/11/17_08:21:46 WARN: File /etc/ha.d/haresources exists.
heartbeat[3926]: 2008/11/17_08:21:46 WARN: This file is not used because crm is enabled

Any idea what is wrong??? How should i start these resources?


Thanks

suse1:/etc/ha.d # /etc/init.d/heartbeat restart
Stopping High-Availability services done
logd[3795]: 2008/11/17_08:21:24 debug: Stopping ha_logd with pid 3475
logd[3795]: 2008/11/17_08:21:24 info: Waiting for pid=3475 to exit
logd[3795]: 2008/11/17_08:21:26 info: Pid 3475 exited
Starting High-Availability services2008/11/17_08:21:46 INFO: IPaddr Resource is stopped
heartbeat[3926]: 2008/11/17_08:21:46 WARN: File /etc/ha.d/haresources exists.
heartbeat[3926]: 2008/11/17_08:21:46 WARN: This file is not used because crm is enabled
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(keepalive,1)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(deadtime,10)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(ping,10.19.146.161)
heartbeat[3926]: 2008/11/17_08:21:46 debug: uid=hacluster, gid=<null>
heartbeat[3926]: 2008/11/17_08:21:46 debug: uid=hacluster, gid=<null>
heartbeat[3926]: 2008/11/17_08:21:46 debug: uid=<null>, gid=haclient
heartbeat[3926]: 2008/11/17_08:21:46 debug: uid=root, gid=<null>
heartbeat[3926]: 2008/11/17_08:21:46 debug: uid=<null>, gid=haclient
heartbeat[3926]: 2008/11/17_08:21:46 debug: Beginning authentication parsing
heartbeat[3926]: 2008/11/17_08:21:46 debug: 16 max authentication methods
heartbeat[3926]: 2008/11/17_08:21:46 debug: Keyfile opened
heartbeat[3926]: 2008/11/17_08:21:46 debug: Keyfile perms OK
heartbeat[3926]: 2008/11/17_08:21:46 debug: 16 max authentication methods
heartbeat[3926]: 2008/11/17_08:21:46 debug: Found authentication method [md5]
heartbeat[3926]: 2008/11/17_08:21:46 info: AUTH: i=1: key = 0x80f13a0, auth=0xb7fdcb94, authname=md5
heartbeat[3926]: 2008/11/17_08:21:46 debug: Outbound signing method is 1
heartbeat[3926]: 2008/11/17_08:21:46 debug: Authentication parsing complete [1]
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(cluster,linux-ha)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(hopfudge,1)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(baud,19200)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(hbgenmethod,file)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(realtime,true)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(msgfmt,classic)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(conn_logd_time,60)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(log_badpack,true)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(coredumps,true)
heartbeat[3926]: 2008/11/17_08:21:46 WARN: Core dumps could be lost if multiple dumps occur
heartbeat[3926]: 2008/11/17_08:21:46 WARN: Consider setting /proc/sys/kernel/core_uses_pid (or equivalent) to 1 for maximum supportability
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(autojoin,none)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(uuidfrom,file)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(compression,zlib)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(compression_threshold,2)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(traditional_compression,no)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(max_rexmit_delay,250)
heartbeat[3926]: 2008/11/17_08:21:46 debug: Setting max_rexmit_delay to 250 ms
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(record_config_changes,on)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(record_pengine_inputs,on)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(enable_config_writes,on)
heartbeat[3926]: 2008/11/17_08:21:46 debug: add_option(memreserve,6500)
heartbeat[3926]: 2008/11/17_08:21:46 debug: displaying uuid table
heartbeat[3926]: 2008/11/17_08:21:46 debug: uuid=de87f19f-9b6f-4617-9195-37d85922a317, name=suse2
heartbeat[3926]: 2008/11/17_08:21:46 debug: uuid=7404fbda-e319-4365-86ea-02a7a5e7bda8, name=suse1
heartbeat[3926]: 2008/11/17_08:21:46 WARN: Logging daemon is disabled --enabling logging daemon is recommended
heartbeat[3926]: 2008/11/17_08:21:46 info: **************************
heartbeat[3926]: 2008/11/17_08:21:46 info: Configuration validated. Starting heartbeat 2.0.5
heartbeat[3926]: 2008/11/17_08:21:46 debug: HA configuration OK. Heartbeat starting.
done 

Open in new window

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.