• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3942
  • Last Modified:

Sound Blaster X-Fi I/O Drive - Not Detected - AD_EXT Cable?

I bought this soundcard: Creative Sound Blaster X-Fi Platinum - Fatal1ty Champion Series
http://www.soundblaster.com/products/product.asp?category=1&subcategory=208&product=16559

I can't get the front interface to work. In the manual it is refered to as the X-Fi I/O Drive which sits at the front of the computer.

I can't find the AD_EXT cable so I am using an old IDE cable. I am keen to get the remote to work and am really annoying I can't get this working!

Please can someone help me?

Where can I buy an AD_EXT cable?
I have emailed their support team but I have read on google that creative's customer supports says they dont sell these anymore so I am a bit desperate and very keen to get this soundcard fully operational as I have waited along time to get to this stage and dont want to wait any longer!
0
shtoom
Asked:
shtoom
  • 2
2 Solutions
 
nobusCommented:
try to make your own - here the pinout:  http://pinouts.ru/Multimedia/sb_audigy2_ad_ext_pinout.shtml
0
 
shtoomAuthor Commented:
mm no thanks..
in the manual it says:
To prevent permanent damage, use only the AD_EXT connector, and the X Fi- audio card with the X-Fi I/O Drive. Do not force any cable into a connector. This can cause permanent damage to your hardware.

I have this error in system device manager under other devices:
Audio device on high definition audio bus driver

Could this be related to the X-Fi I/O Drive?

In Device Manager it has picked up Creative SB X-Fi.

I have an old Soundblaster Live Drive II and I tried using its AD_EXT looking cable but it doesnt fit in my new one: Creative Sound Blaster X-Fi Platinum - Fatal1ty Champion Series 7.1 Sound Card.
I found an old IDE cable i think its 40 pins on each end and it fits into my new. When I turn the computer on the Soundcard connect to the mobo lights up but there is no responce from the front panel X-Fi I/O Drive. indication of the front panel working..
Can someone advise on how to get the front panel working? I think I need the real AD_EXT cable?
0
 
nobusCommented:
if you have an error in device manager, that can be the reason; or the driver is not completely installed, or a bad one, or bad hardware.
try installing another one (older, newer) for testing
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now