localhost/certserv doesnt work, says that the page cannot be found

I have installed Exchange (including OWA) and CA in same box. Now I would like to create new certificate but I cant open localhost/certserv page, ie says that the page cannot be found. I think that this is something to do with Exchange which is in the same box. In my IIS, there is SSL enabled. Anyidea?
thaapavuoriAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nuno MartinsCommented:
Hi,
did you opened https:\\localhost\certsrv ?

The CA must be installed after the Web server to ensure that the Web pages are installed. If the CA is installed first, it still functions, but you may not be able to access the Web pages.
If you installed the CA Web enrollment pages before installing IIS, the required virtual roots are not created. You can create the virtual roots after installing IIS by typing certutil -vroot at a command prompt. The command certutil -vroot does not install the Web enrollment pages. It creates the IIS virtual roots which point to the Web enrollment pages, CA certificate, CRLs, and enrollment controls (xenroll.dll and scrdenrl.dll).
For more information on creating or deleting the related set of Certificate Services Web server virtual roots and file shares, see: http://technet.microsoft.com/en-us/library/cc786960.aspx.
When you initially install IIS, the service is installed in a highly secure mode. Because IIS only serves static content by default, you must enable features such as ASP. To enable ASP and allow the CA Web enrollment pages to work correctly, see Enabling and Disabling Dynamic Content in Microsoft Internet Information Services. : http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/c88ac755-6c61-4562-b488-60976e37e470.mspx?mfr=true

I also recomend that you upgrade Your CA to latest version : http://support.microsoft.com/kb/922706

NM



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thaapavuoriAuthor Commented:
thanks, i will try this tonight when i have time to do it. I tried to open both http:\\localhost\certsrv and https. Just http says that need to use https and https says that page cannot be found.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.