• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 294
  • Last Modified:

Login script is not working

I put a login script in our domain to copy a file from a domain controller to all the machine in my domain. But the file is not copying. Can any one help me out on this. I tried the script as computer/user login script but it won't works. Is there any other way.

Thanks.

The script:
net use u: \\serverdc\scr
u:
copy logo.scr %systemdrive%\ /y/v
%systemdrive%
net use u: /delete
0
valuelabs97
Asked:
valuelabs97
1 Solution
 
ostaehrCommented:
Normally users do not have permissions to write files to %systemdrive% (which should be C:). You should try another path such as %temp% which is inside the user profile path where this user has full access.

Regards, Oliver
0
 
exx1976Commented:
There could also be an issue with user permissions via GPO with the ability to map drives..   Why not just


copy \\serverdc\scr\logo.scr %systemdrive%\ /y/v

?
0
 
ALNMOOCommented:
to test the permission issue run the script in using a user account in his PC if it worked then you need to check is login script applied to his account or not.

run > cmd

Type "gpresult"

You must to see the policy that contains the loign script under

"Applied Group Policy Objects"

Of course you need to run all above in user PC using his account.
0
 
valuelabs97Author Commented:
I tried all above still same
0
 
Donald StewartNetwork AdministratorCommented:
put it in a startup script then it will run under system instead of user and it should work just fine for you
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now