Unintalling : Error 1606 "Cannot Access Network Location x|Ñ"

Hi all,

I am trying to uninstall a program (Blueworld Lasso Professional 6.0.4)
I have an error 1606 "Cannot Access Network Location x|Ñ" when the uninstaller tries to compute the needed space.
I understand that some location (probably a network share / mapped drive) that was available during install is no longer available, but I just can't find which one.
Common solutions to this problem (from MS knowledge base or InstallShield knowledge base) advise to check the registry for incorrect paths in "shell folders" and "user shell folders". All these paths are correct on my system.

I thought that reinstalling the application would do the trick, so I tried to trick it into thinking that it was not installed by removing its registry key from HKLM\Software, but I still get the error (even though it does indeed try a new install).

Any idea ?
Note that the location x|Ñ given is not exact, actually the second character looks more like a null character than like a pipe character, but I'm not sure about that.

Any help would be really appreciated !
LVL 4
thewildAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bruce PieterseTechnical LeadCommented:
Hi,

can you post a screenshot? It might also be looking for the .msi file, if you can locate it, maybe it would fix the problem.

Ciao
0
thewildAuthor Commented:
I can do better thant that. I checked the log file created by the (un)installer, and the exact problematic path is :
Error 1606. Could not access network location xÑ.

That's a very dirty copy/paste, the unreadable character here is a SOH (start of heading) character.

I tried using filemon (from sysinternals), but it logs absolutely nothing from msiexec except its writing to the log file.
0
thewildAuthor Commented:
Hi found the problematic commands in the installer log file (I had to run it from the command line with verbose logging) :

MSI (s) (F0!F8) [12:53:02:492]: PROPERTY CHANGE: Modifying System16Folder property. Its current value is 'C:\WINDOWS\system\'. Its new value: 'xÑxÑ'.
MSI (s) (F0!F8) [12:53:02:492]: PROPERTY CHANGE: Modifying System16Folder property. Its current value is 'xÑxÑ'. Its new value: 'xÑ'.


No idea about where this comes from, or about how to fix it though...
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Vadim RappCommented:
Your property change is after some Action. Need to know the action. The best would be if you could post the whole log.
0
thewildAuthor Commented:
Sure, I should have thought about it in the first place !
Here you go !
debug.log
0
Vadim RappCommented:
as expected, this is done by their custom action - it modifies the property. The only hint is in custom action name "setwebroot" - so maybe you could think if there's anything unusual in your IIS configuration. Maybe install, or uninstall, or reinstall IIS.
Also you can try to repair this product, maybe it will get through; and then uninstall.

If not, then use installer cleanup utility and remove this. If you want clean removal, you can install it again and then uninstall gracefully (if it works then).
0
thewildAuthor Commented:
Uninstalling/reinstalling IIS is not possible.
The only unusual thing I can thin of is that I removed the "default web site". Also, this is IIS 6.0, and the software is quite old so maybe it does not like my server. It installed fine the first time though !

I already tried a repair, and it halted with the same error.
I already tried to remove the software manually (just removed the entries in HKLM\Software), but the re-installation did not want to run...

I think I'll have to live with it...
0
thewildAuthor Commented:
vdimrapp1, you were right about the "setwebroot".
Your suggestion to reinstall IIS was a bit extreme, but as I remembered that this application installed a virtual directory under the default web site, I recreated a fake "Default Web Site".
I had to give it the ID 1 in the IIS metabase using metabase explorer, then the application reinstalled itself just fine !

Thanks for your help !
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.