Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 695
  • Last Modified:

Fedro Linux, Fedro Linux 6, 6

Hi,

 I am having Windows Xp installed on my laptop now I have installed Fedora Linux 6 on my Laptop. Now Default OS to start booting is Fedora Linux 6 instead of Windows Xp. I want Windows XP as default OS to start when I start my laptop.

Thanks
Manoj
0
palhade
Asked:
palhade
  • 4
  • 4
  • 2
  • +1
2 Solutions
 
fosiul01Commented:
you need to chagne this line
default 0 to default 1

at /boot/grub/grub.conf

i gues it 0 , so its booting from fedora

if you do this 1, it will boot from xp
0
 
palhadeAuthor Commented:
Can i do it from Windows XP
0
 
fosiul01Commented:
ommmmm i dont think so, because when you are trying to reboot, boot loader is reading from /grub.conf

if you have 2 dual boot like windows xp and windows 2000 server or something like this

then it would of read from ntldr file,

since it linux its reading from grub.conf

but after loading to windows xp you can try from -> mycomputer -> advanced [ i guess] but i dont think you will see the options to select xp as first booting.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
joolsCommented:
grub is on the mbr, it's easier to just configure the grub under linux to have windows as the default boot.

You can have it controlled by the windows boot menu but you will need to get a dd of the mbr and configure this as the 2nds boot option, it's possible but a bit messy.
0
 
torimarCommented:
It is a lot easier and safer to edit grub.conf in Linux itself.
Do make sure, though, to read and analyze the file before editing, because boot option 1 might also be Fedora Failsafe, so check where in the boot sequence Windows actually resides.

If you still insist on trying to do this from under Windows, there are only 4 tools for accessing linux filesystems from under Windows, and they all have substantial drawbacks:

1. explore2fs: http://www.chrysocome.net/explore2fs
- Does not work with SATA drives (at least not with mine); can only edit files that have write permissions for 'Other' (which hardly any file has, especially not grub.conf)

2. Diskinternals Linux-Reader: http://www.diskinternals.com/linux-reader
- Only grants read access

3. FS Driver: http://www.fs-driver.org
- Must install system driver; only works for Ext2 filesystems

4. ReiserDriver: http://sourceforge.net/projects/rfsd
- Must install system driver; only works with Reiser filesystems

So, if your Fedora sits on a SATA drive formatted Ext3 (which is the most plausible option), there is no way.
0
 
palhadeAuthor Commented:
I tried to access /boot/grub/grub.conf.
 
But I am getting Error message that i do not have permission to do so.
How can i access now /boot/grub/grub.conf. How to set permission
0
 
torimarCommented:
You must access it as root.

Either logout/change user and login with your root account again, or use the "sudo" command in a terminal/run window. To do so, open up a terminal/console window and type:
sudo kedit /boot/grub/grub.conf
(if you use KDE)

sudo gedit /boot/grub/grub.conf
(if you use Gnome)
0
 
joolsCommented:
.... or...
   sudo vi /boot/grub/grub.conf
(actually, probably better to use the kedit or gedit above) :-)
0
 
fosiul01Commented:
if you have root login and password for the system, logon as root
then edit the grub.conf

if you use sudo , then make sure your user name is in sudo list and you have sudo installed in your sytem.
0
 
palhadeAuthor Commented:
Hi,
Following is the content of  /boot/grub/grub.conf file
Please let me know where i need to update in following code
 

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2798.fc6)
root (hd0,1)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-1.2798.fc6.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1
 
Thanks
Manoj
0
 
fosiul01Commented:
according to your Grub.conf

it should boot from windows xp automaticaly

its saying default =1 which is windows xp

so you saying, its does not boot from windows xp automaticaly ??
0
 
palhadeAuthor Commented:
Yes it is not booting from Windows XP
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now