Openreports error while running query reports

Error on Query reports

I am getting the following errors while opening a report which contains a simple query.
(database is mysql and its jdbc driver is already added)
 
javax.servlet.ServletException: /QueryReport.jsp(36,59) Attribute value report.getName() + ".pdf" is quoted with " which must be escaped when used within the value
 
My system specifications
 
OS- RHEL 5
Java - 1.6 jdk
apache- tomcat 5.5

The same openreports work on my centos 5 distribution without any troubles.
 
Please help me to fix it as soon as possible.
 
 
Regards,
 
Alias
crapidontwantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

UmeshSenior Principal Technical Support EngineerCommented:
Set the value of org.apache.jasper.compiler. Parser.STRICT_QUOTE_ESCAPING to false in Apache Tomcat configuration.

Thanks,
Umesh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crapidontwantAuthor Commented:
Thanks for your steps.

Can u give the file name on which this should be done?

I check my server.xml file and didn't find a keywork you mentioned.


Regards,

Alias
0
UmeshSenior Principal Technical Support EngineerCommented:
I'm not 100% sure where to add.. locate setenv.sh and see if they are any settings then add accordingly

-Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false
to setenv.sh

or

org.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false
to setenv.sh.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

crapidontwantAuthor Commented:
yes, I add
CATALINA_OPTS=-Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false variable on catalina.sh file and openreports can now query the output.

Thanks for your valuable input.

Regards,

Alias
0
UmeshSenior Principal Technical Support EngineerCommented:
Anytime..

Thanks,
Umesh
0
UmeshSenior Principal Technical Support EngineerCommented:
From the author comments it seems my comments helped him(11.18.2008 at 05:01PM IST, ID: 22983569)

Thanks,
Umesh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.