• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1996
  • Last Modified:

Domain not showing up with Plesk, but IP address will

We setup a domain using Plesk on our Windows Virtual Dedicated server with an exclusive IP address. When you go to the IP address the website shows up correctly, but the domain does not show anything. The DNS servers are all listed correctly.
I have tryed Reprovisioning the server, and removing and re-adding the domain multiple times with no result.

I have also added the exclusive IP address to the Name servers. The host said something about DNSMng.exe, and I tryed running an Update * with still no results.
0
stconline
Asked:
stconline
  • 9
  • 8
1 Solution
 
Praveen DMInfra Team LeadCommented:
Normally it takes 24 - 48 hrs for a site to resolve to its IP address once the name servers are updates in your domain registeration inc... Please try to ping your site and check if the DNS entries are properlly set in whois DB

 ( Check if your site's name server entries and other details are properly executed if not wait for 24 hrs atleast to get things sorted out automatically)

1. www.whois.ws
2. http://centralops.net/co/
 --> Click -  Domain Dossier ( Left hand top corner)
3. select these -->
domain whois record  
DNS records  traceroute
network whois record
service scan

And check if the result is fine and proper or not ...If you are confident that the entries in your DNS server and at the registrar end is perfect then wait do not modify it and expect it to take effect imdtly.. Cheers Good luck..

0
 
stconlineAuthor Commented:
The entries are correct, and it has been over 78 hours since setup. All other websites are pointing to the shared IP address, this website is the first with its own shopping cart so it needs an exclusive IP for an SSL, but I cannot correctly install the SSL without the domain working.

The Centralops.net/co/ address does not show any information besides the DNS servers when I scan the domain, when I scan the IP address, everything shows up fine.
0
 
Praveen DMInfra Team LeadCommented:
So are you able to

1.In Run prompt Type -  Ping yourdomainname.com -t  ( does it show the proper IP )
2. Are you able to fetch tracert for your site from your PC.
3. Did you try accessing your site in browser in two ways..

i) www.sitename.com
ii) itename.com ( without WWW )

4. Try browsing the site inside the server once.

If Ping does not fetch a positive reply then the rest is useless and also try accessing your site from a proxy link, Maybe your PC FW or AV scanner might be blocking you from accessing your site.., And If you don't mind can u give mention your site name here...
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
stconlineAuthor Commented:
1.) "Ping request could not find host"
2.) "Unable to resolve target system name"
3.) yes, both ways still show "Page cannot be displayed"
4.) Server shows a page cannot be displayed either

Have tryed from different PCs in the office, as well as having some friends in NY try to access it as well with no luck.

the sites domain is www.houseofstyleshopping.com

0
 
Praveen DMInfra Team LeadCommented:
There seems to be a slight mess in DNS at registrar and at your host too..

ns1.edgenetdesign.com[72.167.189.145]  { Actual IP = 72.167.146.167 }
ns2.edgenetdesign.com[72.167.189.145]

If you have given IP at registrar end then modify it accordinglly.... Now check the Entries and "a" records in your DNS server. Being plesk ..It must be Bind DNS and you can check it manually in your Server and modify if there is any IP mismatch entries.

Once done Please flush the DNS cache in your PC and server..
0
 
Praveen DMInfra Team LeadCommented:
Please hold on...

There are different reports in different whois...

http://whois.ws/whois-com/ip-address/houseofstyleshopping.com/

The above link shows that you have edited the entries on 17th ..

NS1.HOUSEOFSTYLESHOPPING.COM --> Not properlly pointed to correct IP in your registrar end..
NS2.HOUSEOFSTYLESHOPPING.COM

Plz Check for ref...

http://reports.internic.net/cgi/whois?whois_nic=ns1.houseofstyleshopping.com&type=domain

So please correct the Name server IP in registrar end first then it will take some time ( Not 24 Hrs..this can resolve quickly based on u r luck ;-) )

Once done..check the DNS entries in your local server...check them well now itself and by end of day or tomrw your site will come online.. cheers good luck...
0
 
Praveen DMInfra Team LeadCommented:
Getting there
1. Point your web browser to http://www.godaddy.com/.

Logging into your account
2. Log into your account by clicking on the "My Account" link located just below the menubar of the webpage. If you don't have an account yet, you will have to create one.
3. Enter your login name or customer number in the entry box labelled "Login Name or Customer Number".
4. Enter your password in the "Password" entry box located below the "Login Name" entry box.
5. Click on the "LOGIN" button located below the "Password" entry box.

Choosing a domain
6. Good! Now that you have logged into your account, select the "Manage Domains" menu item from the "Domain Names" drop down menu located on the left side of the webpage.
7. Below the "Domains Names" menu, select the domain for which you will be creating nameservers. If you do not have any domains, you will have to register one. For example, awebsite.com.

Creating the first nameserver
8. In the bottom right hand corner of the webpage (you may have to scroll down), expand the "Domain Host Summary" box by clicking on the "+" icon.
9. Click on the "Click here to see details or to modify" link below to begin creating the your nameservers.
10. On the right side of the webpage, enter the host name of your first name server in the entry box labelled "Host". The most common names are "ns1" or "dns1". For example, ns1.awebsite.com or dns1.awebsite.com.
11. Just below, add the IP of the nameserver in the "IP Address" entry boxes. For example, 128.98.34.112.
12. Now create the nameserver by clicking on "Add New Host".

Creating the second nameserver
13. You will need to create at least 2 nameservers. To create a second nameserver, repeat steps 10 to 12. Common practice dictates that the second nameserver will be named "ns2" or "dns2". For example, ns2.awebsite.com or dns2.awebsite.com.
14. By convention, the last part of the ip address of the second nameserver will be incremented by 1. For example, 128.98.34.113.
15. At this point you could add additional nameservers but it is not required. To save your nameservers, click on "Save Changes".

Final thoughts
16. Excellent! You have successfully created private nameservers at GoDaddy.com! Remember that your changes may take up to 72 hours to take effect (propagate).

II )

Login to your DNS (Bind ) Server and check the entries carefully ( Manually in DB entries...and edit it manually or through Controlm panel once again..make sure you flush DNS in server and workstation once the process is completed sucessfully...

0
 
stconlineAuthor Commented:
So should I set the houseofstyleshopping.com to have its own Nameservers with its exclusive IP address or should I point them back to the main name servers that all the other accounts share? I tryed doing something similar a day or so ago to see if that would fix it but it still would not show up correctly.

In the name servers for the edgenetdesign.com DNS server, it has options for more than one IP address, should I remove the 72.167.189.145 from the 2nd IP box?
0
 
stconlineAuthor Commented:
Ok, I set houseofstyleshopping.com with Private nameservers pointing to its IP address, re-setup through Plesk, and flushed the DNS server on the server.

Still no result or will this take time?
0
 
stconlineAuthor Commented:
ooo, just saw this, in the Plesk\dns\var folder, there is .com files for every other domain I host, but there is NOT one for houseofstyleshopping.com.

What are these files? And how would I create one for the missing domain?
0
 
Praveen DMInfra Team LeadCommented:
I am sorry If I confused you a litl but... I will clearlly state steps and clarifications in few minutes...
0
 
stconlineAuthor Commented:
the steps were a little confusing as to which domain or name servers I apply them to. I beleive the missing .com files and information from named.conf is causing the problem and I am not too familiar with Plesk, i have used Cpanel on most other hosts.
0
 
Praveen DMInfra Team LeadCommented:
nevermind...Its always better if you can recreate the DNS from plesk CP admin panel .... and flush the local PC nd server
0
 
stconlineAuthor Commented:
Im totally lost as to what steps that last comment entails. The only DNS functions I have in Plesk are the DNS Templates, and I have tryed using the dnsmng.exe tool to update the DNS with no luck
0
 
Praveen DMInfra Team LeadCommented:
For options that can be managed from your plesk CP..plz follow the flash Tutorials that would be very usefull for you and take you to a perfect solution...

http://www.parallels.com/products/plesk/tutorials/
--> Flash Tutorials
----> Managing your DNS zones  

The above would give better understanding instead of many confusions...


**************************************************************************************************************************

Restoring the Original Zone Configuration

To restore the original zone configuration in accordance with the server-wide DNS settings:

Click the Domains shortcut in the navigation pane.
Click the required domain name in the list.
Click the DNS icon in the Services group.
In the IP address drop-down box, select the IP address to be used for restoring the zone, specify whether a www alias is required for the domain, and click the Default button. The zone configuration will be recreated.

To restore the default Start of Authority (SOA) serial number format (UNIX timestamp) for a domain:

Click the Domains shortcut in the navigation pane.
Click the required domain name in the list.
Click the DNS icon.
Click SOA Preferences.
Clear the Use serial number format recommended by IETF and RIPE check box.

Note: See the sample of SOA serial number generated with the selected format. If the resulting number is less, than the current zone number, the modification may cause temporary malfunction of DNS for this domain. Zone updates may be invisible to Internet users for some time.

Click OK.

0
 
stconlineAuthor Commented:
I solved the problem. The zones were all correct and I thank you for your help.

The problem was I was missing a .com file in the Plesk\dns\var name houseofstyleshopping.com. I edited another .com file using the following code :
$TTL      86400
@      86400      IN      SOA      ns.houseofstyleshopping.com. MY@EMAIL.COM. (
      1226931620
      10800
      3600
      604800
      10800)
mssql.houseofstyleshopping.com.      IN      A      72.167.189.145
houseofstyleshopping.com.      IN      A      72.167.189.145
ns.houseofstyleshopping.com.      IN      A      72.167.189.145
mail.houseofstyleshopping.com.      IN      A      72.167.189.145
sitebuilder.houseofstyleshopping.com.      IN      A      72.167.189.145
webmail.houseofstyleshopping.com.      IN      A      72.167.189.145
ftp.houseofstyleshopping.com.      IN      CNAME      houseofstyleshopping.com.
www.houseofstyleshopping.com.      IN      CNAME      houseofstyleshopping.com.
houseofstyleshopping.com.      IN      MX      10 mail.houseofstyleshopping.com.
houseofstyleshopping.com.      IN      NS      ns.houseofstyleshopping.com.

and I also edited the named.conf file in Plesk\dns\etc with the following :

zone "houseofstyleshopping.com" {
      type master;
      file "C:\SWSoft\Plesk\dns\var\houseofstyleshopping.com";
      allow-transfer {
            common-allow-transfer;
            72.167.189.145;
            };
};


0
 
Praveen DMInfra Team LeadCommented:
gr8...thanks for sharing the information...
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now